Support

Home Forums Event Espresso Premium shortcode does not parse

shortcode does not parse

Posted: June 18, 2013 at 5:58 pm


Benjamin Junior

June 18, 2013 at 5:58 pm

Hello,

recently purchased and installed EE, but, after the initial setup, I’m unable to get the shortcodes parsed by the WP. (http://labs.sapo.pt/eventos/?ee=2). I’ve tryed to re-install the package, but without success. If that matters, I’ve installed the free version some weeks ago, and some old data have surfaced on this version.

I saw some posts regarding jquery version of some templates but I’m unable to tell if that’s my problem. I can give login details if needed, please tell me in the correct form to pass the information.

regards

Jr


Josh

  • Support Staff

June 18, 2013 at 8:20 pm

Hi Benjamin,

Can you check to see if the “eventos” page is set to be the main registration page in Event Espresso>General Settings? If it is, it might help to go in to WP>Settings>Permalinks and that will refresh the rewrite rules.

Another thing you can try is to create a new page, place the [ESPRESSO_EVENTS] shortcode on it, then set the new page to be the main registration page in Event Espresso>General Settings.

If none of the above steps help, please send WordPress admin level log in credentials via the contact form on this page:

https://eventespresso.com/send-login-details/


Benjamin Junior

June 19, 2013 at 8:30 am

Hello Josh,

I send the login details in the other form. Some considerations.

I’ve change the permalink strucure from the fancy URLs /%year%/%monthnum%/%postname%/ to the default ?p=123 and the shortcodes start parsing. If I switch back to the Month/name format the shortcodes are not parsed.

Some insigh when I first installed event espresso lite: I’ve deleted the standard pages that are pre-configured, before creating and configura new ones on Espresso. Then I deleted the Light version. Do you think this can be related? Because, as far as I understand, the database fields are not deleted when the plugin is deactivated/unistalled, right?

Regards,

Jr


Josh

  • Support Staff

June 19, 2013 at 9:58 am

Hi Benjamin,

It’s the test page that was deleted, but the main registration page was still set to use the test page as the main registration page. I changed the main registration page back to the default and it’s working now.


Benjamin Junior

June 20, 2013 at 12:55 pm

Hello Josh,

I spend sometime trying to solve several issues with event espresso but, I’m unable to it. The shortcode was intermittent, and I wasn’t able to solve it completely.

So, I decide to erase the plugin and start from scratch.

-I’ve unistalled the plugin through WP dashboard

– I’ve dropped all MySQL tables wp_events_*

-I’ve erased every reference to “%espresso%” in wp_options table

Installed a fresh file of EE, the installation processed created all tables and the default pages that I haven’t touch. Created a event that You can see here:

http://labs.sapo.pt/event-registration/?ee=1

The problem that I was unable to solve – this time – was the error:

Error 404 – Nothing Found

The page you are looking for could not be found.

when I submited the form.

I really believe that something is very wrong, but I can’t track it down. I guess you still have the login credentials I have sent you.

Please advise.

Jr

 


Josh

  • Support Staff

June 20, 2013 at 1:06 pm

Hi there,

That’s the problem I saw earlier, and it was resolved by changing the main registration setting back to what it was by default. It’s still working when I check it out:

screenshot


Benjamin Junior

June 20, 2013 at 1:10 pm

Hello Josh,

Yes, the registration page is working but, if you submit something in the form, you get the error I’ve mentioned. Can you try to submit some data?

Regards,

Jr


Josh

  • Support Staff

June 20, 2013 at 1:23 pm

Hi Benjamin,

I think you’ll need to disable the custom permalinks feature (by setting the permalink option to use the default permalink structure) until you can manually update the .htaccess file -or- fix the permissions for .htaccess so that WordPress can update the .htaccess file


Benjamin Junior

June 20, 2013 at 1:26 pm

But wordpress have permissions to do that. Check:

junior@vm-wpress:/home/www/labs.sapo.pt$ ls -las .htaccess

4 -rwxrwxr-x 1 www-data www-data 235 Jun 20 20:24 .htaccess

The Apache server runs unde www-data:www-data… so no issues with lack of permissions. EE need to save some information on .htaccess?


Josh

  • Support Staff

June 20, 2013 at 1:33 pm

What happens when you switch to the default permalink structure?


Benjamin Junior

June 20, 2013 at 1:36 pm

The problem persists… page not found when I submit the form with the information.


Josh

  • Support Staff

June 20, 2013 at 1:54 pm

The next step would be to do this:

You can reate a new page, place the [ESPRESSO_EVENTS] shortcode on it, then set the new page to be the main registration page in Event Espresso>General Settings.

You can try this with permalinks on and off as well.


Benjamin Junior

June 20, 2013 at 1:59 pm

Nope… no success… created the new page, changed the settings, try with and without fancy urls 🙁


Josh

  • Support Staff

June 20, 2013 at 2:22 pm

Hi there,

Can you post a link to the new page so we can take a look?


Benjamin Junior

June 20, 2013 at 3:22 pm

sure: http://labs.sapo.pt/ee-eventos/?ee=1

also, you have the login credentials


Josh

  • Support Staff

June 20, 2013 at 3:50 pm

Hi Benjamin,

It looks like it’s a conflict with the Events made Easy plugin. The event form went to the confirmation page as expected after I deactivated it.


Benjamin Junior

June 20, 2013 at 4:26 pm

You are right, thank you Josh. I deactivate the Events Made Easy plugin.

Two final tweaks:

1 – I’ve activated the option “Enable attendee pre-approval feature?”, and activate the pre-aproval in one event. But when I click in “Awaiting approval” link to approve the attendee, i get this message in the attendee payment record “Fatal error: Call to undefined function is_attendee_approved() in /home/www/labs.sapo.pt/wp-content/plugins/event-espresso/includes/admin-reports/enter_attendee_payments.php on line 583”

2- Trying to upload a feaured image to the event, results only on a broken image link. Can’t see any featured image in the event.

help me on this and I’ll give you a break for today 🙂

Thx

Jr


Dean

June 21, 2013 at 2:57 am

Hi,

I can confirm that error, I have raised a developer ticket to look into it.

Regarding the image do you have an example? Have you checked the URL is correct and that the file is accessible?


Benjamin Junior

June 21, 2013 at 3:18 am

Hello Dean,

Thank you, the first issue is not critical so I can wait.

The second issue: I have tried several approaches. Upload a new file through the drag&drop interface, and add the image. And selected a existent image im de media bank. I can confirm the the image exists, appears in the WP Media interface correctly and is accessible via permalink.

thoughts?

 


Dean

June 21, 2013 at 3:33 am

Strange.

We still have login details for you, do you have any objection to me logging in and doing some tests?


Benjamin Junior

June 21, 2013 at 3:58 am

Dean, please be my guest. If you want, please be free to create a test event and experiment on it.

Also be free to enable/disable plugins in the test. Let me know if you want some log file, I have shell access.


Dean

June 21, 2013 at 4:34 am

Hi Benjamin,

Thanks. I did a quick test event with a featured image and it worked fine. I also added an image (now removed) to the active event and again, no issues with it.

Can you advise what image you used? Did you upload it from a file or via the media list etc?


Benjamin Junior

June 21, 2013 at 4:59 am

Dean,

When uploading or selecting the image, I missed that the field “Link URL”, to my user, was blank. I assumed that when pressing “insert on article”, all the information needed was passed in the background, which is not.

So, that’s solved, it was the standard problem between the monitor and the chair 🙂

Thank you so much – Dean and Josh – for all your excellent  support.

About the problem of the pre-approved feature, I’ll wait for a new release.


Dean

June 21, 2013 at 5:04 am

Great! Glad its working now!

The support post ‘shortcode does not parse’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso