Support

Home Forums Event Espresso Premium Shopping cart is missing!?!?!?

Shopping cart is missing!?!?!?

Posted: June 25, 2014 at 2:50 pm


Meg McCauley

June 25, 2014 at 2:50 pm

So things were working great, until today and I’m not entirely sure what occurred.

We have an event using the multiple events shortcode:
[ESPRESSO_CART_LINK event_id=”25-4″ anchor=”Register for Professional Practices Exchange and Awards Dinner” direct_to_cart=1 moving_to_cart=”Redirecting to cart…”]

This was directing just fine to the proper cart to fill out. Now, all its saying is:
“It looks like you are attempting to refresh a page after completing your registration or your cart is empty. Please go to the events page and try again.”

I tried changing the shortcode and nothing. All of the other single events work great by the way. Any help in this as soon as possible would be amazing!

THANK YOU!


Lorenzo Orlando Caum

  • Support Staff

June 25, 2014 at 3:22 pm

Hello,

Any recent changes to the site such as plugin installs or updates?

Is a caching plugin or service in use?

Could you also go to your site in an alternative web browser and try registering (related to caching plugins)?


Lorenzo


Meg McCauley

June 25, 2014 at 3:28 pm

I’m trying it in Firefox and it’s just churning, never goes anywhere.

I did change the way Jquery was being called, but I just removed that from the functions and this appears to be the same. That’s the only thing I can think of that was changed since yesterday. Is this borked?


Meg McCauley

June 25, 2014 at 3:29 pm

Just tried it in Safari and the same thing happens as in chrome.


Lorenzo Orlando Caum

  • Support Staff

June 25, 2014 at 3:35 pm

Was the jQuery fix needed to fix the other events?

If not, could you try reversing your changes and re-testing?


Lorenzo


Meg McCauley

June 25, 2014 at 3:53 pm

Negative, it was not. I did reverse the changes and same thing.


Meg McCauley

June 25, 2014 at 4:50 pm

Any update would be greatly appreciated!


Lorenzo Orlando Caum

  • Support Staff

June 25, 2014 at 5:55 pm

Hi,

Could you temporarily switch the site into defaults with only Event Espresso running and retest?

Please also ensure that the default WordPress pages with the four shortcodes are published and are set correctly in Event Espressos General Settings.


Lorenzo


Meg McCauley

June 25, 2014 at 6:24 pm

I can not, no. This is running on a live site that just went live. I will check the 4 pages.

Anything else you can think of, will a look at the page help?


Lorenzo Orlando Caum

  • Support Staff

June 25, 2014 at 7:50 pm

Hi,

Thats the only recommendation I have at this time. Event Espresso can not make changes on its own so this may be from a recent change or another plugin.


Lorenzo


Josh

  • Support Staff

June 26, 2014 at 8:57 am

Hi Meg,

Yes, a look at the page will definitely help. Since time is of the essence and we’d really like to see your site get back up and running I did a little investigating and found your site by Googling the anchor text for your cart link.

Anyway, this looks like an issue where wp-admin ajax is being forced to load as *https*. This can really mess up the front end of the site’s ajax if the front end loads as *http*. If you view the source of the main event reg page you’ll see something like this:

var EEGlobals = {"ajaxurl":"https:\/\/yoursite.org\/wp-admin\/admin-ajax.php","plugin_url":"http:\/\/yoursite.org\/wp-content\/plugins\/event-espresso\/","event_page_id":"69"};

The https and http protocols shouldn’t be mixed like this. When they are the web browser will freak out and you’ll see messages like this one in the console:

> Given URL is not allowed by the Application configuration.: One or more of the given URLs is not allowed by the App’s settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App’s domains.

You can look to see if the admin part of WordPress site is being forced to load as https. Usually it’s a plugin or a definition set in the wp-config.php file that’s used to set this up. It’s totally fine (and even recommended) to set up the admin this way, but when you do, you’ll need to also secure the front end pages.

So you can fix this by, at the very least, setting the page that has the [ESPRESSO_EVENTS] shortcode and any page that has the [ESPRESSO_CART_LINK] shortcode to also be secured with https.

We recommend the WordPress HTTPS plugin to secure these pages, and we have step by step documentation you can follow:

http://eventespresso.com/wiki/espresso-sslhttps/


Meg McCauley

June 26, 2014 at 12:28 pm

Thank you!

I managed to get the events and cart working now. A side note however that may help perhaps to add to the tutorial page.

In the HTTPS plugin I installed, it allowed me to secure the pages you mentioned. However, after I made this change and secured those pages, the cart page just rolled back to the events list.

I found the filter section of the plugin, where you can a specific url section to secure. I have my events list listed as oregonhospice.org/register-for-events

I added /register-for-events/ to the filter list to secure and this made it work! I hope this makes sense? Cause it’s beneficial to maybe add to the support for others who may have the same issue.

Thank you, thank you, thank you!!!

The support post ‘Shopping cart is missing!?!?!?’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Meg McCauley 5 years, 5 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!