Support

Home Forums Event Espresso Premium Screen Ghosting while working in events, but not while working in wordpress

Screen Ghosting while working in events, but not while working in wordpress

Posted: February 16, 2021 at 9:01 am


Kbradley5

February 16, 2021 at 9:01 am

The last few times I have been working on my events, my screen ghosts and kicks me back up to the top. Ive looked to see if something has changed. It does not happen anywhere else in my word press, only while in event espresso. I have pictures. It is extremely frustrating, and I need help!


Tony

  • Support Staff

February 16, 2021 at 9:16 am

Hi there,

Apologies but I don’t follow the ghosting reference, however, if its only happening within EE and pushing you to the top of the page it may be the help tours.

Go to Event Espresso -> General Settings -> Admin Options

Change ‘Activate Global Help Tours?’ to No and save does that fix it?

You can include screenshot by hosting the image on the site and then posting the link here, or using a 3rd party app. See here:

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots


Kbradley5

February 16, 2021 at 10:07 am

it already was NO for global help tours, Ill send a screen shot now


Kbradley5

February 16, 2021 at 10:49 am

the ghosted https://childbirthconcierge.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-16-at-10.17.52-AM.png

normal https://childbirthconcierge.com/wp-content/uploads/2021/02/Screen-Shot-2021-02-16-at-10.17.10-AM.png


Tony

  • Support Staff

February 16, 2021 at 12:47 pm

Hmm, strange.

So that overlay is usually triggered when there is a modal displayed.

If you open up Chrome Dev Tools (or similar) and look in the console section, do you see any errors?


Kbradley5

February 16, 2021 at 1:49 pm

I am not a programmer at all small business owner so be gentle with me what or where do I look for Chrome Dev tools? I am sorry 🙁


Kbradley5

February 16, 2021 at 2:03 pm

ok so one thing I just realized is that when I go to delete a ticket with NO registrations it ghosts me every time, so in essence I can not delete.

So this is pretty serious now :_(


Tony

  • Support Staff

February 16, 2021 at 2:07 pm

I can’t reproduce this, so it’s most likely a conflict from some other plugin on the site running scripts on the event editor.

Can I take a look in the admin to see if there are any errors? If so, you can send temp login details using this form:

https://eventespresso.com/send-login-details/

(Note, I do not need FTP credentials for this, you can leave those blank. Just credentials to log into the wp-admin side of your site)


Kbradley5

February 17, 2021 at 4:53 am

This reply has been marked as private.


Tony

  • Support Staff

February 17, 2021 at 6:14 am

Which browser are you using?

I’m not getting the above at all, I tested on a new event and created datetimes and tickets. Then deleted those again an nothing happened, the datetimes/tickets were deleted from the page without any issues.


Kbradley5

February 17, 2021 at 10:35 am

Chrome


Tony

  • Support Staff

February 17, 2021 at 10:37 am

Can you add the steps you take to reproduce this, please?

I’ve not had any instances of the above.

Have you tested in another browser at all? If not, try it and see if you get the same.


Kbradley5

February 17, 2021 at 10:56 am

This reply has been marked as private.


Kbradley5

February 17, 2021 at 11:21 am

ok I think we figured it out. I was trying to delete a “Event Date-times” with OUT first deleting the associated ticket. It would then go ghosted/dark and kick me to top of screen.

I realized I have to delete the ticket 1st, then the Event Dates/time. I hope this is it, still doesn’t explain why it was “ghosting” me when I had my cursor just sitting on the page. Thanks


Tony

  • Support Staff

February 17, 2021 at 1:05 pm

Ok, that’s the info I needed above, the steps you were taking to cause the problem.

With that, I’ve found the cause. The ‘ghosting’ happens when a model is shown, so in your case, this is what should be shown: https://monosnap.com/file/iGAZhe43Lclxkbz9rQi4fDf03irnnW

The overlay is there to highlight the modal (the ‘popup’) but on your site that isn’t visible because another plugin is loading styles that override the ones EE uses.

I’ve created a ticket to work around this on the next release of Event Espresso.


Kbradley5

February 18, 2021 at 6:03 am

Thanks Tony! So most likely there was an update in my site or EE that changed something? As this wasn’t happening before. Am I understanding correctly?


Tony

  • Support Staff

February 18, 2021 at 6:39 am

This hasn’t changed in EE for a long time now, so its more likely another plugin, but yes that’s correct.

I can tell you where the rule is coming from as I can see it on your site but it doesn’t mean its an issue specifically from that plugin.

/wp-content/plugins/allure/includes/wp-full-auto-tags-manager/assets/vendor/bootstrap-3.3.6-dist/css/bootstrap.css

Is setting up this rule:

.hidden {
    display: none !important;
}

EE uses the hidden class and then changes the display property inline to display the modal, however, the hidden class isn’t removed so then the modal remains hidden because of the !important; in the above.

The next version of Event Espresso removes the hidden class when the modal is displayed and re-applies it when it’s hidden again.

(I know this won’t really mean much to you, but if you pass it onto your web developer it should mean something to them).

That explains why you don’t get anything shown when your page is showing the overlay is shown (what you are calling Ghosting) but not why the overlay is shown in the first place as it will be showing you a message of some sort, but right now it’s hidden. It is happening randomly when editing an event and not just when deleting a DateTime? If so we need to know what that modal says when that happens randomly for more info.


Kbradley5

February 18, 2021 at 1:08 pm

It is “ghosting” sometimes when my curser is just sitting there.


Tony

  • Support Staff

February 18, 2021 at 3:02 pm

Install this plugin on the site:

https://en-gb.wordpress.org/plugins/add-admin-css/

Go to Appearance -> Admin CSS

In the bottom box, add this:

.ee-admin-dialog-container.auto-hide.hidden {
    display: inherit!important;
}

Save.

Now get the page to ghost again, does it show the modal this time? IF so, what error?


Kbradley5

February 23, 2021 at 5:22 am

here is a message that just came up

The maximum number of inputs on this page has been exceeded. You cannot make edits to this page because of your server’s PHP “max_input_vars” setting.
There are 1019 inputs and the maximum amount currently allowed by your server is 1000.
Please contact your web host and ask them to raise the “max_input_vars” limit.


Tony

  • Support Staff

February 23, 2021 at 5:51 am

Ok, so that happens when you’ve created enough datetimes and/or tickets within a single event to reach your servers max_input_vars limit.

You’ll need to contact your host and have them increase the above setting, doubling it will allow you to create roughly twice as many datetimes/ticket as you have now within the event.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 week, 1 day ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!