Support

Home Forums Community Forum Save Button on main EE settings page

Save Button on main EE settings page

Posted: August 9, 2021 at 10:23 pm


azlro

August 9, 2021 at 10:23 pm

Seems we can no longer save changes under the main EE General settings page, none of the tabs has a “save” button, or “update settings” button… everything else works from what I can tell..


azlro

August 9, 2021 at 10:24 pm

WP 5.8, EE 4.10.13.p


Tony

  • Support Staff

August 10, 2021 at 4:17 am

Hi there,

If you open up Event Espresso -> General Settings.

Click on the ‘Screen Options’ tab on the top right of the page.

You should see 2 checkboxes, one with ‘Update Settings’ and another with ‘New @ EVent Espresso’, is the ‘Update Settings’ checkbox checked?


azlro

August 10, 2021 at 6:17 am

Yea it’s checked. I tried unchecking it, no change, also tried different machines with different browsers.


Tony

  • Support Staff

August 10, 2021 at 8:30 am

Hmm, strange.

Are you logged in as a full administrator?

Go to Event Espresso -> Maintenance -> Reset/Delete Data.

Click the ‘Reset Event Espresso Capabilities’ only (other options there will delete EE data).

Same issue?


azlro

August 10, 2021 at 8:40 am

Yep, I’m logged in as full admin… I tried to reset the capabilities to no avail.. all other EE functions seem to work fine and I can update / add at will.

it’s just the “general settings” page, “your organization”, “critical pages”, “admin options”, “Privacy” tabs do not have a “save”, “apply”, “update” button of any kind after making changes.. Only the “country” tab has a button that says “save country details”


Tony

  • Support Staff

August 10, 2021 at 10:25 am

Thats just…. odd!

Mind if I take a look? If thats ok I’ll need temp login details which you can send using this form:

https://eventespresso.com/send-login-details/


azlro

August 10, 2021 at 11:21 am

sent


Tony

  • Support Staff

August 10, 2021 at 11:41 am

How do you update Event Espresso on the site?

The section you are referring to is actually loading on the page, but the styles from within which would force it to display are missing. The CSS file within the plugin is empty, so none of the styles apply and the box is hidden offscreen.

Have you customized Event Espresso at all? If not the first thing I would do is reinstall EE.

Download the latest version from your account page.

Save the .zip somewhere you can find it easily.

On the site go to Dashboard -> Plugins -> Add new -> Upload plugin -> select the .zip you just downloaded.

(Note you don’t need to deactivate or delete the current version of Event Espresso before updating, the version of WordPress you are using will detect the current version and ask if you want to replace it with the .zip you just uploaded…. if it doesn’t show you a message asking what to do, stop here as there is more to which will need to be investigated)

Replace the current version with the version you just downloaded and retest.

I’ll post a private reply after this to the file, it should show various CSS styles but right now it’s an empty file.


Tony

  • Support Staff

August 10, 2021 at 11:42 am

This reply has been marked as private.


azlro

August 10, 2021 at 12:56 pm

Thanks for the quick response, we haven’t done any customizations to the site at all.

I have to manually download and FTP the plugin to our ./plugins/ folder every time..

for some reason the dashboard “update plugins” feature doesn’t work for us, it fails at some copy..

So I manually uploaded that zero byte CSS file and the problem persists.. So, I’ll re-install the entire thing now and try again.. I’ll pay close attention to any failed FTP uploads.


Tony

  • Support Staff

August 10, 2021 at 2:11 pm

When you use FTP, are you first deleting the previous version?

You could create a new event-espresso-core-reg-temp directory and install to that, then rename the original version to -temp2 and remove -temp from the ‘new` version.

If you’re overwriting the original directory and just replacing the contents, that won’t work.

I’d recommend working through why you can’t use the WP plugin updater as it’s much more reliable than the above method.


azlro

August 10, 2021 at 3:14 pm

Good catch on the missing CSS file, I re-installed the entire product and now it works..

As far as the install steps, I do remove the prior version, before FTPing the new version up…

FTP is not ideal and I think we have issues with our host that we need to iron out, since any WP updates also crash everything..

Thanks for your help !


Tony

  • Support Staff

August 10, 2021 at 5:23 pm

You’re most welcome and I’m glad it’s working.

We often see people just using FTP and replacing overwriting the entire directory so thought I’d mention it but obviously, you’re already on the ball 🙂

Any other issues/questions just let us know.

The support post ‘Save Button on main EE settings page’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso