Home Forums Event Espresso Premium Registration & Payment not working

Registration & Payment not working

Posted: January 26, 2013 at 1:47 am


January 26, 2013 at 1:47 am

I am hoping someone can help me. On my new website, I am using event espresso. When I fill out the registration form, it doesn’t go anywhere. The form disappears but I am left on the registration page. On my event overview, I get listed as an attendee, but I don’t get directed to pay-pal to make any payments and no confirmation emails go through.

I have configured my pay-pal. I have read through some threads on here and tried various things – I have deleted and re-installed event espresso. I have added the [raw][/raw] tags to my [EVENT_ESPRESSO] page, but this just makes the [raw][/raw] visible on my page.

I have checked all pages are public, and have the correct [codes] on them. I have tried both turning on the payment confirmation page and turning it off. I am baffled…

I have been successfully running event espresso with paypal for almost a year on a another website, and I have checked all the settings and seem to have configured the new sight the same (and have disabled event-espresso from the old site).

My website is I am running theme twentyeleven version 1.5 and I am running wordpress version 3.5.1. My hosting is through hostgator.

Can someone please help?
Thank you!


January 26, 2013 at 10:25 pm

I have just purchased a support token – how do I go about using it to get help with this? Thanks.


January 28, 2013 at 5:50 am


Sorry for the delay in responding.

You are running the JetPack plugin. Can you turn off the Publicize and Sharing modules and check to see if this resolves the issue?

If so, we will have a fix in the next release of Event Espresso.

If not please advise and I can look into it in more depth.


January 28, 2013 at 10:08 pm

Hi Dean,

According to my Jetpack Plugin settings, I don’t have sharing or publicize activated. I also uninstalled the newest version of Jetpack and went back to the older version. Same issue, even when Jetpack was completely deactivated.

I have sent you a reply email with login details. Thanks!


January 29, 2013 at 5:10 am


It looks like Seth picked up your email and got it working for you.


  • Support Staff

January 30, 2013 at 8:43 am

This was what Seth found:

I found the issue. You had “Force HTTPS on Return URL” turned on in your payment settings, but you don’t have an SSL installed on your server. It looks like everything is working now.


January 31, 2013 at 12:16 am

Hi! Thanks so much for all the help. Everything is pretty much working ok now, except that I now have this on the bottom of every page on my website

Fatal error: Class ‘FilesystemIterator’ not found in /home/admin/public_html/ on line 1353.

What do I do to get rid of this?


January 31, 2013 at 4:43 am


You are running a Beta version of Event Espresso. The 3.1.30 release is now out, updating to that may resolve the error.


  • Support Staff

January 31, 2013 at 7:36 am

It will resolve this, because the filesystemiterator class was removed in the official version since that class is not compatible with installations of PHP below version 5.3.


February 1, 2013 at 1:11 am

Thanks so much =)

The support post ‘Registration & Payment not working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso