Support

Home Forums Event Espresso Premium Quickbooks Gateway Challenge

Quickbooks Gateway Challenge

Posted: November 2, 2017 at 4:33 pm


TVCT

November 2, 2017 at 4:33 pm

I’ve been carefully following the instructions to set up the Quickbooks plugin to accept payments via E.E. but am coming across some challenges.

First, I’m instructed to click both the ‘payments’ and ‘quickbooks’ boxes in the intuit developer. There is only a Quickbooks Account and Quickbooks Payments option available. I can pick both but I’m not sure that is correct.

I am also instructed to Copy and Paste my Company ID from Intuit Developer into the Quickbooks Plugin field. No such field exists for this information so I put it in the *Name field. Not sure if that is correct.

Third problem, I continue to receive the same error message when I try to connect the plugin to Quickbooks:

We’re sorry!
The redirect_uri query parameter value is invalid. Make sure it is listed in the Redirect URIs section on your app’s keys tab and matches it exactly. Click here to learn more about the redirect_uri query parameter.

I’m not finding any instructions about adjusting the URI field. I found that field in Intuit developer but it already has a code in it and I’m hesitant to change it with no ideas as to what to change it too.

Any ideas?


Tony

  • Support Staff

November 3, 2017 at 3:43 am

Hi there,

Are you following the instructions here?

https://eventespresso.com/wiki/quickbooks-payment-gateway/

First, I’m instructed to click both the ‘payments’ and ‘quickbooks’ boxes in the intuit developer. There is only a Quickbooks Account and Quickbooks Payments option available. I can pick both but I’m not sure that is correct.

Quickbooks payments are required, but you can select both if you prefer.

I am also instructed to Copy and Paste my Company ID from Intuit Developer into the Quickbooks Plugin field. No such field exists for this information so I put it in the *Name field. Not sure if that is correct.

No, don’t use that field. To confirm you mean this one – http://take.ms/2HJnc

If so put that back to ‘Quickbooks’, it’s the name used within EE to identify that payment method (It can be anything you want really, but I wouldn’t put the Company ID there). Company ID is actually no longer required by Quickbooks so I’ll get that removed from the docs.

One problem with Quickbooks is they changed their integration and it depends on when you created your account which type you will have (annoying but that’s the way it goes 🙂 )

If this is a new account you’ll be using oAuth 2.0 and when looking within your intuit account and grabbing the key info it will look like this – http://take.ms/JvMLK

If you keys section looks like that then you select oAuth 2.0 in the quickbooks payment method and input the keys in their relevant sections – http://take.ms/GaikJ

If you have an older account your keys look like this – http://take.ms/uaOxW

if so you select oAuth 1.0a in the Quickbooks payment method and input the details were needed – http://take.ms/tEUIr

(By the above I think your oAuth 2.0)

Third problem, I continue to receive the same error message when I try to connect the plugin to Quickbooks:
We’re sorry!
The redirect_uri query parameter value is invalid. Make sure it is listed in the Redirect URIs section on your app’s keys tab and matches it exactly. Click here to learn more about the redirect_uri query parameter.

The redirect_uri needs to be set for your site.

If you go to Event Espresso -> Payment methods.

In the top right click the Help section, then ‘Quickbooks Settings’.

There you’ll find a section under oAuth2.0 that shows your redirect_url, copy that (be sure you get the trailing slash at the end).

Now, back to your intuit account and under where you got the keys from you’ll find the redirect_url settings. You can have up to 5 set at any one time, so you can leave the one that’s there (no need, but it’s up to you) – http://take.ms/j6zAU

Hit save to save your new redirect_url.

Note that Quickbooks requires that URL loads over https for production servers, sandbox/development testing can use http, but live must use https.

Now refresh the payment method settings page and try to connect your app, does it work?


TVCT

November 3, 2017 at 11:06 am

Tony – you identified the problem and your step by step instructions were spot on! THANK YOU!!! I am now connected and able to start testing. I’m sure this won’t be my last challenge as I am new to this but I have to tell you how impressed and thankful I am to the EventEspresso team! From our very first communication you all have been superb! You saved my little nonprofit from the Big Bad EventBrite price increase and your tools are giving me more freedom to represent my events the way I want too. I’m excited to share my experience with other NPs looking for a better solution! THANK YOU!


Tony

  • Support Staff

November 6, 2017 at 5:06 am

Thank you for the feedback, I’ll pass it on to the rest of the team.

We’d really appreciate if you could share your EE experience and maybe write a review:

https://eventespresso.com/recommend-event-espresso/#review

No pressure to do so it just helps us spread the word, either way I’m glad the above worked for you and any further question/problems just let us know.

The support post ‘Quickbooks Gateway Challenge’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 1 year, 9 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!