Support

Home Forums Pre-Releases Promotions doesn't work with Stripe Gateway activated

Promotions doesn't work with Stripe Gateway activated

Posted: June 29, 2015 at 7:51 pm


eugenesudbury

June 29, 2015 at 7:51 pm

Hey!

I noticed that the submit button for the promotions ad on doesn’t work when Strip Gateway is activated.


Josh

  • Support Staff

June 30, 2015 at 6:32 am

Hi Hannah,

That shouldn’t be an issue in the current build of the promotions add-on pre-release. However, there is one issue that we have a ticket for where a message erroneously displays that says the promo code isn’t valid after checking out with Stripe.


eugenesudbury

June 30, 2015 at 6:44 am

Hi Josh,

I’ve recreated he problem on a couple different installations – as soon as the stripe gateway is activated the button becomes flat and unclickable. As soon as stripe is deactivated the button becomes clickable again and the promo applies. I’m getting that problem with Chrome, Firefox, Safari, and IE.


Josh

  • Support Staff

June 30, 2015 at 7:23 am

Hi Hannah,

I’m going to assume you’re not running the current build. You can get the current builds of EE4.8 beta and the promotions add-on from github. Here are direct links to their repositories:

https://github.com/eventespresso/event-espresso-core/tree/BETA-4.8-CORE

https://github.com/eventespresso/EE4-Promotions

Please be sure that you pull the latest from the BETA-4.8-CORE branch, as the promotions add-on will not activate with EE4 core Master.


eugenesudbury

June 30, 2015 at 9:04 am

Hi Josh,

I’m using the latest versions. I was wrong – it’s not happening to me when the plug in is activated. It’s happening when Stripe is selected at checkout. If Invoice is selected then the button becomes clickable, but once Stripe is selected is becomes unclickable.


Josh

  • Support Staff

June 30, 2015 at 9:30 am

Hi Hannah,

Can you double check the version numbers of the plugins and let us know the exact version number of EE core and Promotions that are active? Thanks.


eugenesudbury

June 30, 2015 at 11:28 am

EE: 4.8.0.rc.004
Promo:1.0.0.rc.071


Josh

  • Support Staff

June 30, 2015 at 2:42 pm

I was able to reproduce this, but only if Stripe was set to open by default. If Stripe isn’t set to open by default, the button for submitting a promo code will still work. There will be an update to the Stripe gateway before promotions is officially released. The update will include a change to prevent the submit promo code button from being disabled.


Josh

  • Support Staff

July 3, 2015 at 2:15 pm

Hi Hannah,

The issue you reported here was fixed in a recent commit. You can pull the latest from the EE4-Promotions Github repo to get the fix.

The support post ‘Promotions doesn't work with Stripe Gateway activated’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Beta test upcoming software through the pre-release channel. Learn more about the pre-release channel.

Status: closed

Updated by  Josh 5 years, 1 month ago ago

Topic Tags

Tagged: ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!