Support

Home Forums Event Espresso Premium Problems with E-Mail Generation

Problems with E-Mail Generation

Posted: March 12, 2018 at 9:02 pm


website@secpta.net

March 12, 2018 at 9:02 pm

Hi there,

Up until just about a week ago (apparently – just checked and noticed this), e-mail generation has been fine. Now all of a sudden I have a lot of backlogged e-mails that never went out. And when I try to send them to get them out of the queue, not all are leaving the queue.

For example, for a barage of “payment received” emails, I see them in the queue and that are tagged to go to a specific sender, and when I click the wrench icon, I get the following message on a subsequent screen:

“Incoming data for the Gateways data handler must have an EE_Transaction object as the value for the first array index. EE_Messages_Gateways_incoming_data – __construct – 51”

I also get that message while trying to select the bulk settings for individual emails as such above – “Generate Now”, “Generate ad Send Now”, Queue for Resending”, etc.

I’m not sure what might be the problem here. Have never had these issues before. I use “GMAIL SMTP” to send email which is working as I’ve just tested it, and it has worked beautifuly in the past.

Any ideas on how I should approach this problems?

Thanks,
Marshall


website@secpta.net

March 12, 2018 at 9:06 pm

I’m also receiving the following message too:

An error has occurred:
The messages were not sent. This could mean there is already a batch being sent on a separate request, or because the selected messages are not sendable. Please wait a minute or two and try again.

Can’t get around that error either.


Josh

  • Support Staff

March 13, 2018 at 8:13 am

Hi Marshall,

Those errors are related to caching where the underlying temporary data for those messages got lost due to garbage collection from the caching mechanism.

If you’re running caching on your site you can avoid this issue by going to Event Espresso > Messages > Settings and set messages to Send on the Same Request. Any messages currently in the backlog will need to be deleted.


website@secpta.net

March 13, 2018 at 5:31 pm

Thanks, Josh. I haven’t fundamentally changed anything about the caching on my website, and have not had a problem with the generation of any EE messages until now. I did as you suggested and it fixed the problem. However, my concern is that it will place undue drag on the server and possible cause other issues, especially if others are also trying to register and/or do other things on my website at the same time. Thus, is there a way for me to adjust any other setting on EE or on my website so I can still have the messages get batched together and sent? My website is currently on WP-Engine and I use WP Rocket as my caching plugin.

Thanks,
Marshall


Tony

  • Support Staff

March 14, 2018 at 4:28 am

The timing for the garbage collection had to trigger at just the right time to cause the above.

Do you know the specific version number of Event Espresso you were running when this error first started?

You can find a log of when you updated EE within Event Espresso -> Maintenance -> System information -> ee_activation_history to see when you updated.

Also, with the above setting your not adding additional load on the server, the difference is that when a registration is made and you click to complete a payment the emails are generated and send on that same request, so it may take slightly longer for the user to be directed to the thank you page.

The load on the server is the same, it just happens at a different time.


website@secpta.net

March 21, 2018 at 9:10 pm

Hi Tony,

Sorry for the late reply. I believe the version/time I updated is this one: 4.9.58.p 2018-03-11 19:45:07.

Also, I just finished testing a few things on this with WP Engine support. They enabled their alternate cron to see if the issue with “generate on a separate request” was related to the default cron. After they made their switch and I reverted EE back to the separate request, the same result occurred. So now I have it back to the same request.

I see what you are saying about the timing. So maybe it won’t be an issue.

In any case, I’m seeing the following type of error message get generated ever time an email is generated. Any ideas why this might be the case?

[Wed Mar 21 18:34:42.260978 2018] [:error] [pid 2174] [client 35.184.217.171:41791] —————————————————————————————-\n[2018-03-21 18:34:42] Exception Details\nMessage: Incoming data for the Gateways data handler must have an EE_Transaction object as the value for the first array index.\nCode: EE_Messages_Gateways_incoming_data – __construct – 51\nFile: /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/data_class/EE_Messages_Gateways_incoming_data.class.php\nLine No: 51\nStack trace: \n#0 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Generator.lib.php(919): EE_Messages_Gateways_incoming_data->__construct(Array)\n#1 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Generator.lib.php(889): EE_Messages_Generator->_set_data_handler(Array, ‘EE_Messages_Gat…’)\n#2 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Generator.lib.php(760): EE_Messages_Generator->_validate_and_setup_data()\n#3 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Generator.lib.php(153): EE_Messages_Generator->_verify()\n#4 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Processor.lib.php(124): EE_Messages_Generator->generate()\n#5 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/modules/messages/EED_Messages.module.php(292): EE_Messages_Processor->batch_generate_from_queue()\n#6 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Scheduler.lib.php(150): EED_Messages->run_cron()\n#7 /nas/content/live/secpta/wp-content/plugins/event-espresso-core-reg/core/libraries/messages/EE_Messages_Scheduler.lib.php(165): EE_Messages_Scheduler::initiate_immediate_request_on_cron(‘generate’)\n#8 [internal function]: EE_Messages_Scheduler::batch_generation()\n#9 /nas/content/live/secpta/wp-includes/class-wp-hook.php(286): call_user_func_array(Array, Array)\n#10 /nas/content/live/secpta/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)\n#11 /nas/content/live/secpta/wp-includes/plugin.php(515): WP_Hook->do_action(Array)\n#12 /nas/content/live/secpta/wp-cron.php(126): do_action_ref_array(‘AHEE__EE_Messag…’, Array)\n#13 {main}\n—————————————————————————————-\n, referer: https://www.secpta.net/wp-cron.php?doing_wp_cron=1521657280.6880729198455810546875


Tony

  • Support Staff

March 22, 2018 at 4:10 am

Did you remove all of the previously queued ‘broken’ emails from the queue?

The support post ‘Problems with E-Mail Generation’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 6 months, 1 week ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!