Support

Home Forums Event Espresso Premium Problem with EE4 Upgrade – Admin Page Redirects

Problem with EE4 Upgrade – Admin Page Redirects

Posted: August 2, 2014 at 9:42 am


Greg Scherrer

August 2, 2014 at 9:42 am

I attempted to upgrade my site from EE3 to EE4 last night and ran into some issues after the upgrade. After restoring a DB backup to downgrade to EE3, I’m unable to apply the EE4 upgrade at all. I’m hoping someone might recognize this issue and help me understand how to proceed.

First of all, I was running 3.1.36.5.P and attempted to upgrade to the current GA release, 4.2.9.p, following the instructions here: http://eventespresso.com/wiki/updating-event-espresso/

After backing up the database, I was able to install and activate the plug-in. The admin pages came back up in full maintenance mode, and I began the migration, which completed successfully. Aside from some funniness with one event, which I determined I’d resolve manually, the updates appeared to be successful based on a scan of events and registrations. I then installed/activated the calendar add-on for EE4 and completed its migration. The site was displaying the calendar successfully.

Somewhere along the way, my admin pages stopped loading. This didn’t seem to be tied to any specific action. I would get errors such as the following in Firefox:

The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.

Since I couldn’t load any admin pages, I restored my database backup and completed the rollback to EE3. I then tried a fresh upgrade to EE4 following the same instructions.

As soon as I activate the EE4 plug-in now, I see the same redirect errors. My site loads fine, but wp-admin pages won’t load and get that redirect error. This is repeatable through several restore/re-upgrade cycles. I’ve now completely rolled back to EE3, so the site is in a stable state. I would like to figure out what went wrong so that I can complete the upgrade, though.

As background, my site runs at http://mysite.org (site name changed), and I’ve got the Force SSL for admin pages option set, so that login and admin pages go to https://mysite.org. I tried disabling that option in WP-Config, and it didn’t seem to help. I ensured that redirection plugins were disabled and checked for any strange .htaccess entries that might be causing the problem.

I found that if I comment the contents of this function in /core/EE_System.core.php, I can get the admin pages to load after a fresh upgrade to EE4. However, even if I manually navigate to admin.php?page=espresso_about, it doesn’t display the EE3 –> EE4 upgrade prompts.

public function redirect_to_about_ee() {
if( is_admin() ){
$url = add_query_arg( array( 'page' => 'espresso_about' ), admin_url( 'admin.php' ) );
wp_safe_redirect( $url );
exit();
}
}

Any ideas?


Lorenzo Orlando Caum

  • Support Staff

August 4, 2014 at 8:03 am

Hi,

When you attempted the upgrade a second time, did you try temporarily deactivating other plugins?


Lorenzo


Greg Scherrer

August 4, 2014 at 7:09 pm

I didn’t the other day, but I tried again tonight with all plug-ins disabled. The same redirect behavior occurred.

Since I was going to need to run a database restore anyway, I also tried using the current preview version (v4.3.0.beta.024). It had the same result. I had to roll back again. Any ideas?


Tony

  • Support Staff

August 5, 2014 at 7:27 am

Hi Greg,

Have you tried switching the sites theme? You can do this using Theme Test Drive which will allow admins to use another theme whilst user still see the current active theme. Install that plugin and test drive one of the default themes such as TwentyFourteen and see if the issue remains.

However, rather than working on the live site, I would recommend duplicating the site either locally or to a development server and running through troubleshooting there.

Personally I use the Duplicator plugin for this for speed but there are multiple choices.


Greg Scherrer

August 5, 2014 at 7:36 pm

Tony, no, the theme was not an issue.

I did follow your suggestion to pull the site down locally. The upgrade applied fine there. This suggested the remaining differences were environmental.

I made two updates. I’m not sure which of these fixed the problem, but I believe one of them did:

  • Disable PHP Xcache (server-side)
  • Remove some remaining vestiges of W3 Total Cache from .htaccess and some files in the wp-content directory that weren’t grouped with the plug-in

So, the good news is that the upgrade applied successfully. Hopefully by sharing this, someone else can benefit from the troubleshooting experience — it’s probably a good idea to disable all caching completely.


Lorenzo Orlando Caum

  • Support Staff

August 5, 2014 at 9:04 pm

Hi, thanks for sharing that solution with the community.

Its possible that the cache became “old” and did not clear on its own. You can run a caching plugin with Event Espresso but no cache rules are needed:

http://eventespresso.com/wiki/setup-nocache-exclusion-rules-event-espresso/


Lorenzo


Greg Scherrer

August 6, 2014 at 4:28 am

Lorenzo,

Thanks for sharing that link — very helpful!

-Greg

The support post ‘Problem with EE4 Upgrade – Admin Page Redirects’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Greg Scherrer 5 years, 2 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!