Support

Home Forums Event Espresso Premium Problem with EE table template

Problem with EE table template

Posted: December 24, 2014 at 7:23 am


Benjamin Nizet

December 24, 2014 at 7:23 am

Hi,
I have the add-on running here :
http://www.enseignons.be/cours/inscription
but the category filter and the search doesn’t work 🙁
Can you help ?


Josh

  • Support Staff

December 24, 2014 at 8:57 am

Hi Benjamin,

It looks like you have something that’s concatenating the JavaScript on the page (Pagespeed?) which may be putting the scripts in the wrong load order.

This is the error when I view the page in the console:

Uncaught TypeError: undefined is not a function

If you turn off the pagespeed feature where it’s concatenating the scripts, does the issue persist?


Benjamin Nizet

December 24, 2014 at 9:27 am

Hi,
Pagespeed is a widely used module for speeding up websites…
I can’t turn it off just for this :
https://developers.google.com/speed/pagespeed/module


Lorenzo Orlando Caum

  • Support Staff

December 24, 2014 at 9:41 am

Hi, it looks like there is an option to exclude certain pages through the service:

https://developers.google.com/speed/pagespeed/module/restricting_urls


Lorenzo


Josh

  • Support Staff

December 24, 2014 at 9:44 am

It’s also possible to configure pagespeed so that the scripts load in the correct order. For example, some scripts need to load in the head. If a script that is required to load in the head of the document is changed to load in the footer, it won’t be loaded in time for its dependent scripts.

If you use Pagespeed, that’s fine, but you will need to be sure to configure things correctly so that scripts load in the correct order. Otherwise, some scripts will not work.


Benjamin Nizet

December 25, 2014 at 3:55 am

Have you any idea which ones are required in the head section for EE4 ?


Benjamin Nizet

December 25, 2014 at 8:56 am

By the way, why are dates shown as English dates, while they look OK in the CPT or in my wordpress in general?


Josh

  • Support Staff

December 26, 2014 at 9:35 am

Hi Benjamin,

The scripts that need to run from the header will vary depending on which theme you have installed.

You can find out where the scripts normally load by temporarily deactivating pagespeed’s concatenation. Once you have that information, you can configure pagespeed so that the scripts load where they need to.

The reason the template doesn’t translate the dates is it doesn’t run the date_i18n() function. We’ll be sure to add date_i18n() to the next version. In the meantime, you can add it by opening up the table template file and change where it says echo $startdat; to this:

echo date_i18n( $date_format . ' ' . $time_format, strtotime( $startdat ) );

and add the following near the top of the file:

// Options
$date_format		= get_option( 'date_format' );
$time_format		= get_option( 'time_format' );
  • This reply was modified 4 years, 10 months ago by  Josh. Reason: code formatting


Josh

  • Support Staff

January 6, 2015 at 12:47 pm

Hi there,

The fix for the issue you reported here is included in the update to the Events table template plugin (version 1.3.1.p).

The support post ‘Problem with EE table template’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 4 years, 10 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.