Home Forums Event Espresso Premium Primary question group not displaying on forms

Primary question group not displaying on forms

Posted: August 15, 2012 at 5:06 pm

Eric Amundson

August 15, 2012 at 5:06 pm

So we have a multi-site install of EE, and the other Super Admin created the primary question group. Right now it only has First Name (which doesn’t display on the registration form anyway). I can’t edit it. When I view the Question groups there are two “tabs” My Groups and All Groups. It is displaying in All Groups and I can click on edit, but updating it doesn’t do anything or give any errors.

At a bit of a loss to be honest. It it related to the EE permissions plugin?

Seth Shoultes

  • Support Staff

August 15, 2012 at 9:42 pm

I think this is related to the EE permissions plugin. You might try deactivating that addon then re-saving the questions.

Just curious are you logged in as an “administrator” when trying to edit the these particular questions?

Eric Amundson

August 16, 2012 at 9:09 am

I deactivated the plugin and the primary question group is still not displaying on the event registration page.

Interesting enough, I solved the inability for me to edit the primary question group. I was logged in as an admin, but when we migrated from our temporary domain name to the registered domain name when we launched it somehow killed all of our auto_increment flags in our database. I went through and added them all back manually but missed the question groups ones. Adding the auto_increment flags back on the primary key (id in those cases) allowed me to edit the question groups.

They are still not displaying though 🙁

Also, I made the mistake of registering our key on the temporary domain ( and now to reset it to just http://domain.tld I need to pay, right, I don’t see any other way to do that)

Eric Amundson

August 16, 2012 at 9:36 am

Adding $question_groups[1] = 1; to the registration_page.php file after line 171 where $question_groups is assigned makes the form show up.

Not sure why it wasn’t getting added to the original array though. I’m ok with this “McGuyver solution” but also interested if you have a hypothesis.



  • Support Staff

August 16, 2012 at 9:56 am

I’ll go ahead and reset the key for you. What method(s) did you use to move the db over when you migrated the site?

Eric Amundson

August 16, 2012 at 11:45 am

Thanks Josh! We used BackupBuddy to make the necessary database changes (the files all remained in the same place). We’ve not had that happen before though, maybe because it is multi-site?


  • Support Staff

August 16, 2012 at 12:22 pm

We seem to get a lot of reports like these whenever BackupBuddy is used to migrate a site. There was another topic that was resolved yesterday, and the original poster mentioned that after updating BackupBuddy to the latest version, they tried again and the issue was resolved.

The support post ‘Primary question group not displaying on forms’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso