Support

Home Forums Pre-Sales Presales – Event Espresso Multiple Event Plugin

Presales – Event Espresso Multiple Event Plugin

Posted: July 19, 2016 at 12:28 pm


jgold723

July 19, 2016 at 12:28 pm

I have EE3.1.21P. I want to add the Multiple Event plugin, but it says I need to have at least EE 3.1.33. Do I need to purchase that update? What is the cost of that?


Tony

  • Support Staff

July 20, 2016 at 3:08 am

Hi there,

For EE3 you can pricing for our licenses here:

https://eventespresso.com/pricing/?ee_ver=ee3

All of the license include updates for the core plugin however the personal license does not include the EE3 Multi Event Registration Add-on (MER for short) so you can eidther purchase the Personal License and EE3 MER add-on or purchase the Business License which does include the add-on.

However, before moving forward have you consider updating to EE4?

You can find a comparison chart between the 2 versions here:

https://eventespresso.com/differences-ee4-ee3/

and can also Test Drive Event Espresso 4 to see if it will suit your needs.


jgold723

July 25, 2016 at 12:31 pm

Question about the upgrade. Once I purchase the license, will I install the latest version of EE3 over my existing installation (Version 3.1.21.P). Or is there a different upgrade method?


Lorenzo Orlando Caum

  • Support Staff

July 25, 2016 at 3:58 pm

Hello,

Your version of Event Espresso 3 is from 2012 (https://eventespresso.com/wiki/change-log/#3.1.29.1).

One-click updates are unlikely to be available. However, you can manually upgrade and we have a guide for that here:

https://eventespresso.com/wiki/how-to-upgrade-event-espresso/

Before, making any changes on your we definitely recommend backing up your WordPress site (e.g. https://eventespresso.com/wiki/how-to-back-up-your-site/).


Lorenzo


jgold723

July 26, 2016 at 7:19 am

Hi Lorenzo — thanks for the link to the manual update instructions. It appears I will need to disable and delete my current EE3 install and then reinstall the updated version. Will this also delete all my data (events)? Will I need to recreate these?

Thanks,

John


Tony

  • Support Staff

July 26, 2016 at 8:44 am

All of your EE data including the events themselves, registrations, settings etc is all stored within the database. We do not remove any data when the plugin is de-activated/removed so No you will not lose any of your data when your manually update.

However we do always recommend creating a database backup before performing any updates (not just EE updates but any plugin, theme or WP updates) just to be safe. There are many backup plugins available to help with this, here is one I use:

https://en-gb.wordpress.org/plugins/backupwordpress/

Also to answer your question:

Question about the upgrade. Once I purchase the license, will I install the latest version of EE3 over my existing installation (Version 3.1.21.P). Or is there a different upgrade method?

It depends on what features you need.

If you rely on all of the existing features of EE3 then you’ll want to stick with EE3 and update to the latest version. To do that you just update to the latest version of EE3 and continue as normal.

If you do’t need all of those feature and EE4 suits all of your needs I would recommend updating to EE4. If you update to EE4 when you first activate EE4 will ask if you want to migrate your event data, I recommend you do so. EE4 will then pull all of the information from EE3 that it can in EE4.

EE4 works differently than EE3 so you’ll want to confirm it works how you expect, the best way to do that is to update a development copy of your site first and check over that.

You can find a comparison here:

https://eventespresso.com/differences-ee4-ee3/

The main feature preventing users from updating to EE4 is recurring events as it does not currently support them, EE3 does with the recurring event manager.


jgold723

July 26, 2016 at 8:55 am

Thank you very much. We are using the recurring event manager, so we’d need to stick with EE3. Question — our version of Recurring Events is 1.1.4. Will that be compatible with the latest version of EE3, or will need need to upgrade that as well?


Tony

  • Support Staff

July 26, 2016 at 9:12 am

The latest version of the recurring events manager (REM for short) is 1.1.8

1.1.4 should be compatible with the latest version of EE however we test add-ons based on the latest version of EE and I would highly recommend updating to the latest version of REM.

The support post ‘Presales – Event Espresso Multiple Event Plugin’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso