Support

Home Forums Event Espresso Premium Practicing in PayPal Sandbox

Practicing in PayPal Sandbox

Posted: July 16, 2012 at 5:43 am


Kirk Tirakian

July 16, 2012 at 5:43 am

I have succeeded in getting Event Espresso to work with PayPal sandbox to a degree. When I follow the rules here: http://eventespresso.com/forums/2011/03/testing-your-paypal-ipn/ I get the same results. So I’m guessing that once I’ve succeeding with these steps a real live PayPal buyer account and seller account interacting will not require Step 7 or STEP 8 for Event Espresso to realize the buyer has paid?? Is there another practice setup that shows/depicts a more normal sequence of events that I would see with actual PayPal accounts? Thanks

  • This topic was modified 8 years, 4 months ago by  Josh. Reason: moving to correct forum topic category


Josh

  • Support Staff

July 16, 2012 at 12:12 pm

Steps 7 and 8 are for testing the IPN directly from the PayPal sandbox account interface.

You can register for the event and test the registration + payment process by 1) logging into your PayPal sandbox account. 2) Enter a sandbox seller account in Event Espresso’s PayPal settings (be sure to check the “Use Sandbox” option and save) 3) Use a sandbox buyer account username + password when testing the registration + payment process.


Kirk Tirakian

July 17, 2012 at 10:15 pm

Okay still not getting a paid attendee confirmation without doing the Steps 7 and 8.

I did the three steps you outline assuming the username looks like this name_1XXXXXXXXX_per@gmail.com where “per” means personal account. So I put the name_1XXXXXXXXX_per@gmail.com in to the email field where Event Espresso registration is only asking for First Name, Last Name, and Email.

  • This reply was modified 8 years, 4 months ago by  Kirk Tirakian.


Josh

  • Support Staff

July 18, 2012 at 7:30 am

I would input a real email address in the email field on the Event Espresso registration page. Then use the PayPal sandbox buyer account address when you’re on the PayPal screen.

Make sure the PayPal settings are set up with a Sandbox seller account and the debugging feature is active:
paypal settings

Then make sure you are logged into the PayPal Sandbox account in the same browser while your’re testing the registration in Event Espresso using the sandbox.


Kirk Tirakian

July 18, 2012 at 11:19 am

Hi Josh,

My PayPal settings panel looks like the example you provided.
I’ve got name_1XXXXXXXXX_biz@gmail.com as you have josh . . . . biz@yourdomain.com

I’m using only one browser. It is Chrome, Version 20.0.1132.57, on a Dell 9150 desktop running Ubuntu 12.04 operating system.

I’m logged into the PayPal Sandbox while I’m practice registering. I believe I have done all the steps correctly.


Josh

  • Support Staff

July 18, 2012 at 11:49 am

Can you provide a little more detail about what is happening after you fill out the registration form>confirm the confirmation page and hit the payment option page?


Kirk Tirakian

July 18, 2012 at 12:48 pm

Sure! After I fill out the registration page and hit “submit” I’m taken to the confirm page which has 2 “Confirm Registration” buttons on it. Is there supposed to be two buttons??:

PLEASE VERIFY YOUR REGISTRATION DETAILS:
EVENT NAME: Who’s Driving Your Bus 08.25.12
PRICE PER ATTENDEE: $5.00
ATTENDEE NAME: Kirk Wednesday3 (kirkxxxxxx@mydomain.com)
TOTAL PRICE: $5.00
Confirm Button (justified to the left)

ADDITIONAL INFORMATION FOR: KIRK WEDNESDAY3
FIRST NAME Kirk
LAST NAME Wednesday3
EMAIL kirkxxxxxx@mydomain.com
Confirmation Button (justified to the left)

Then, I click on one or the other of the confirmation buttons which takes me to the payment options page. I click on the PayPal button which takes me to the PayPal Sandbox payments page: https://www.sandbox.paypal.com/us/cgi-bin/webscr?c . . . . . . .

I put in my personal practice account email address and password. Then it takes me to a page where I have check the check box. Then I think it is the final confirm payment page ending with the Thank You page as I recall.


Josh

  • Support Staff

July 18, 2012 at 1:22 pm

That sounds like it’s working to me. The two confirmation buttons are supposed to be there. Imagine a long registration form where there are lots of questions. The button at the bottom is there so the registrant will not need to scroll back to the top of the page to confirm.


Josh

  • Support Staff

July 20, 2012 at 11:58 am

Hey Kirk,

The ipn_results.log you sent showed successful transfers, but only dated from 7/12/2012. There should be more recent ones since you’ve been testing this. Did the site get moved after 7/12? If so, check the file/folder permissions of the /wp-content/uploads/espresso/log folder and make sure that this is writeable.


Kirk Tirakian

July 23, 2012 at 9:38 am

Hi Josh,

log folder has permission 755 which I understand to be good. I did not move anything yet.

Could the updating cause this? Could deactivating and activitating re-set this?

Thanks,

Kirk


Josh

  • Support Staff

July 23, 2012 at 9:45 am

Try 777 for the /espresso/logs directory. Moving from one server to another would more than likely make a difference if the servers are configured differently.


Kirk Tirakian

July 23, 2012 at 1:57 pm

I tried 777 on the log directory and the paypal.ipn_results.log file inside with no luck. I’ve tried deactivating all event Espresso plugins and re-activating them. While that fixed the missing PAYPAL button graphic problem, it did not make a difference to the attendee overview or the log. Neither did deactivating most of the plugins other than the Espresso ones.

Anything else to suggest I try?


Josh

  • Support Staff

July 23, 2012 at 2:05 pm

Have you checked to see if cURL is enabled on this server? The Event Espresso requirements plugin can run a quick check if you install it: http://eventespresso.com/requirements/


Kirk Tirakian

July 24, 2012 at 9:41 am

Good Morning Josh,

I’m sending you the page printout pdf of the Event Espresso Requirements. (via email)

I see bluehost.com is one of the hosts you guys like the most.
That is what I am using here.

Here are the warnings and what I tried to do if anything:

WARNING
Your server appears to have PHP error reporting set to E_STRICT (or some similar combination of error reporting constants). This is not recommended in a production environment. You may change this at runtime by modifying your wp-config.php file. Click here to get the code to add to your wp-config.php.

Action-I pasted the code given into the wp-config.php file at the end of the file. Looks like it didn’t effect it.

WARNING
The recommended version of MySQL is 5.5 or higher.

Action-Tried to see if there was a way to set a higher version. I even called Bluehost.com. They are at 5.1.63
and that is where they plan to be.

WARNING
Your site may be vulnerable to spam registrations without the Apache module mod_security active on your server. We recommend enabling reCAPTCHA on the Event Espresso General Settings page to avoid spam registrations.

Action-Enabled reCAPTCHA using my primary domain, http://www.kirktalon.com, not http://www.kirktalon.com/thrufire cause reCAPTCHA didn’t like that. STILL geting the warning so that isn’t right either.

INFORMATION
You appear to be on a MediaTemple­powered site. Please note that we have historically seen various issues on
MediaTemple shared servers. Consult their support documentation or log in to your AccountCenter if you have any
problems with your site.

Action-I’m not aware of using or going to the MediaTemple­powered site(s) and adding anything from there to this site.
Don’t know how to deal with this.

WARNING
Some recommended Apache modules appear to be missing from your installation. While this may not cause
any obvious errors, some features may not work correctly. Please contact your webhost about activating
additional Apache modules or upgrading Apache.
Apache function apache _get _modules() not found! This could have to do with your PHP version or your PHP configuration. Please contact your webhost.
pcegtmdls) Click here for more information about apache_get_modulesd ( ) pcegtmdls)

Action-Talked to Bluehost about this and the guy helping me didn’t understand it. (My opinion)

Then there was the last one about an htaccess file. I know there is one in the espresso log folder you had me explore buy I still don’t know
what to do here.

Please advise,

Kirk


Josh

  • Support Staff

July 24, 2012 at 11:47 am

The main thing we are looking for is whether or not cURL is enabled on this server. If it is enabled, and you’re still not getting any new logs written to the paypal ipn log, then I would recommend deactivating all non-EE plugins and re-testing.

The other items are warnings and recommendations. I would be concerned with leaving the error_display on if that is indeed the case. This can also be set to off by editing php.ini. The espresso requirements plugin is an automated test, so you should check phpinfo() to verify this first. It will look something like this:
enter image description here


Kirk Tirakian

July 25, 2012 at 7:54 am

I turned off all non-EE plugins and made sure Display_errors was “off”. Tried registering twice. Everything is working as it should except paypal ipn log and payment confirmation in Attendee Overview not getting the message.


Josh

  • Support Staff

July 25, 2012 at 8:37 am

Hi Kirk,

Do you have a live PayPal account ready to go? If so, try running a test on that by registering for a cheap event (you can use an event priced at a $.05 or something like that) and see if that makes a difference. Be sure to verify that the IPN is turned on for this account.


Kirk Tirakian

July 25, 2012 at 2:20 pm

Okay, I’ll have to get with my client and see if he went ahead and upgraded his PayPal to business type. Otherwise would scraping my current practice accounts and getting new ones possibly make a diff?


Josh

  • Support Staff

July 25, 2012 at 3:16 pm

I don’t think so. I did a little research on this and discovered today that PayPal has been having problems with their sandbox IPN: http://bit.ly/Q5HmPm

So until PayPal gets this fixed, it looks like the only way to test a transaction with PayPal would be use a live account.

I can recommend a very good alternative: http://stripe.com You can set up a free account in minutes and the account will have a test mode. Then plug the test credentials into the Stripe gateway settings. Note that Stripe will give you both live and test creds, use the test creds and set the settings on both your site and the Stripe account to test mode.


Kirk Tirakian

July 26, 2012 at 9:03 pm

Hi Josh,

The stripe.com did the trick. Everything appears to be working now. A lot of correspondence for PayPal’s problem.

Thanks,

Kirk

The support post ‘Practicing in PayPal Sandbox’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!
[i]
[i]