Support

Home Forums Event Espresso Premium Plugin stopped working correctly with no errors

Plugin stopped working correctly with no errors

Posted: September 1, 2020 at 11:36 am


daria2b

September 1, 2020 at 11:36 am

I’ve been having trouble using the plugin in the past couple of weeks for no apparent reason.

The biggest issue I’m experiencing right now is that I cannot open the Advanced settings on the tickets. When I click on the gear icon nothing happens, no error messages, nothing at all. It’s very important for me as I need to collect tax on my tickets and this setting is only available via the advanced settings.

In addition, I cannot create new tickets. When I click “Create ticket” it just updates the page instead.

I’ve also noticed that the date picker is not opening when I click on the date fields. I have to type in the date manually.

I didn’t make any changes to the plugins or the setup, it just stopped working. I need to fix it asap as I have new events coming up next week.


Tony

  • Support Staff

September 1, 2020 at 3:03 pm

Hi there,

All of the functions you’ve mentioned use JavaScript to function, if are any JavaScript errors being thrown on the page it prevents any additional code from running.

So, on the event editor open up Chrome Dev Tools and check in the ‘Console’ section, any errors shown there?

WordPress 5.5 pushed some breaking changes for a lot of plugins and whilst EE4 hasn’t been affected so far if there are other plugins adding scripts that then throw errors it can cause the above.


daria2b

September 3, 2020 at 12:09 pm

When I tried to open advanced settings for tickets or tried to create a new ticket I got this error logged in the console:

Uncaught TypeError: e(...).live is not a function
    at Function.e.ukai_tag_editor (ukaitag.min.js?ver=2.1.5:1)
    at HTMLDocument.<anonymous> (ukaitag.min.js?ver=2.1.5:1)
    at i (jquery.js?ver=1.12.4-wp:2)
    at Object.fireWith [as resolveWith] (jquery.js?ver=1.12.4-wp:2)
    at Function.ready (jquery.js?ver=1.12.4-wp:2)
    at HTMLDocument.J (jquery.js?ver=1.12.4-wp:2)

What should I do next?


Tony

  • Support Staff

September 3, 2020 at 12:19 pm

Ok so that means the code in ukaitag.min.js needs to be updated, that’s not from Event Espresso and I don’t recognize it. If you hover over the filename it should give you the path, which then should tell you where it’s from.

In any case, this isn’t something we can fix within EVent Espresso but you can ‘fix’ the current issue by installing this plugin:

https://wordpress.org/plugins/enable-jquery-migrate-helper/

The problem is the above is trying to use functions from jQuery that have been removed from the version that ships with WordPress, the above plugin adds a ‘migrate’ script that adds those functions back in. It is not intended as a permanent solution but should get things working again whilst updating plugins/the theme/whatever code is causing the errors.


daria2b

September 3, 2020 at 12:44 pm

Thank you. The plugin solved the issue that I saw in EE. I can see what plugin caused the problem in the first place, however, I can’t disable it right away, I’ll need to find an alternative.

Btw, the Jquery plugin is throwing this error:

This page generated the following warnings:

https://scrummastered.com/wp-content/plugins/event-espresso-core-reg/core/admin/assets/ee-admin-page.js: jQuery.fn.unload() is deprecated


Tony

  • Support Staff

September 3, 2020 at 1:14 pm

Would you mind letting me know the plugin? Just so I can keep track of issues and known conflicts, you can mark your reply private so only EE staff can see it, or if you prefer not too that’s also fine.

Btw, the Jquery plugin is throwing this error:

Thank you, we are aware of that deprecated notice but it won’t cause issues until jQuery 3.0 (when the function is removed from jQuery) which will be a while before it’s include in WP yet. We’ll get that fixed up before then.


daria2b

September 3, 2020 at 1:16 pm

It the Youzer plugin (https://youzer.kainelabs.com/), but I’m using an older version since I downloaded it for free. Not sure if more recent versions actually solve that issue.


Tony

  • Support Staff

September 3, 2020 at 1:23 pm

Thank you 🙂

If there is anything else we can help with just let us know.


daria2b

September 3, 2020 at 1:40 pm

That’s all. Currently, the problem is solved and I know what’s causing it so I can fix it if it persists.
Thank you


Tony

  • Support Staff

September 3, 2020 at 1:57 pm

You’re most welcome, glad you up and running again.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 month, 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!