Support

Home Forums Event Espresso Premium PHP 8 Error Log message – Compatibility with PHP 8

PHP 8 Error Log message – Compatibility with PHP 8

Posted: November 21, 2022 at 1:05 am


Praxis

November 21, 2022 at 1:05 am

Hello

We are testing Event Espresso with PHP 8 and we are seeing the following PHP message in the Error Log.

2022/11/20 15:51:23 [error] 115599#115599: *2921 FastCGI sent in stderr: "PHP message: PHP Deprecated: Required parameter $transaction follows optional parameter $TXN_total in /www/xyz/public/wp-content/plugins/eea-promotions/EED_Promotions.module.php on line 335 PHP message: PHP Deprecated: Required parameter $event follows optional parameter $html in /www/xyz/public/wp-content/plugins/eea-wait-lists/domain/services/modules/EED_Wait_Lists.module.php on line 28 5PHP message: PHP Deprecated: Required parameter $ticket_selector follows optional parameter $html in /www/xyz/public/wp-content/plugins/eea-wait-lists/domain/services/modules/EED_Wait_Lists.module.php on line 285 PHP message: PHP Deprecated: Required parameter $active_message_types follows optional parameter $reg_status_actions in /www/xyz/public/wp-content/plugins/eea-wait-lists/domain/services/modules/EED_Wait_Lists.module.php on line 521 PHP message: PHP Deprecated: Required parameter $can_send follows optional parameter $reg_status_actions in /www/xyz/public/wp-content/plugins/eea-wait-lists/domain/services/modules/EED_Wait_Lists.module.php on line 521 PHP message: PHP Deprecated: Required parameter $form follows optional parameter $wait_list_spaces_left in /www/xyz/public/wp-content/plugins/eea-wp-user-integration/EED_WP_Users_Ticket_Selector.module.php on line 244" while reading response header from upstream, client: 79.131.111.110, server: staging-xyz.kinsta.cloud, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php8.0-fpm-xyz.sock:", host: "staging-xyz.kinsta.cloud:64823", referrer: "https://staging-xyz.kinsta.cloud/wp-admin/plugins.php"

We plan to move to PHP 8 soon, so please let me know when you plan to make the plugin and its add-ons compatible with it.

Thanks.

Haris


Sam

  • Support Staff

November 21, 2022 at 3:52 am

Hi Casey,

Thank you for contacting us today.

I have checked the website and can see that you are using the older version of the plugin.

Please update the plugin to the latest version (V4.10.40) for a better result.

Thank you.


Tony

  • Support Staff

November 21, 2022 at 4:41 am

Hi there,

Event Espresso 4.10.40+ is fully compatible within PHP8.0

The deprecated notices you’ve included above don’t highlight an ‘incompatibility’ as such, they are deprecated notices which means PHP8 is saying “We’ve changed something which means this code is no longer correct, for not it works but in a future version (like PHP8.1) it will throw an error”.

We have a ticket to fix these in an upcoming update to the add-ons but they will work as is with PHP8.0 currently.

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso