Support

Home Forums Event Espresso Premium php 8.0

php 8.0

Posted: November 22, 2021 at 9:15 am


angelhealing2

November 22, 2021 at 9:15 am

Just wondering if EE and the addons are compatible with php 8.0 yet? Thank you.


Tony

  • Support Staff

November 22, 2021 at 3:54 pm

Hi there,

The short answer to this is no, EE is not currently fully compatible with PHP8.

Event Espresso itself will throw warnings and deprecated notices with PHP8 but for the most part, work fine. However, I do know that the DOMPDF library we currently use to generate PDF’s is not compatible with PHP8 and will throw a fatal error, meaning you wont be able to generate Invoice/Receipt PDFs.

We are working to make Event Espresso PHP8 compatible in the future but as it stands recommend using PHP7.


angelhealing2

November 24, 2021 at 8:36 am

Hi Tony, thank you for the update. Hopefully soon as PHP 8.0 offers a lot of great benefits including speed.


Tony

  • Support Staff

November 24, 2021 at 11:02 am

Agreed, however, a lot of the WP dev environment doesn’t support PHP8 just yet and it’s holding us some.

It is in the works πŸ™‚

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso