Support

Home Forums Event Espresso Premium PHP 8.0 support

PHP 8.0 support

Posted: May 30, 2021 at 4:14 pm


ndaniel

May 30, 2021 at 4:14 pm

Hello,
Has EE4 (4.10.11.p) been tested with PHP 8.0?
I thought it wise to check prior to updating. Thanks!


Tony

  • Support Staff

June 1, 2021 at 9:06 am

Hi there,

We have tested Event Espresso 4 core with PHP8 and need to add some fixes for it as it will run but throws notices on methods that have now been deprecated in PHP.

We have not tested the functionality of all of the add-ons on PHP8 but we do know of an issue within the EE4 Stripe add-on that throws a fatal error and also the WP User integration add-on (the fix for which is needed in core).

You must be logged in to reply to this support post. Sign In or Register for an Account

Event Espresso