Support

Home Forums Event Espresso Premium Permalink is not displaying Events

Permalink is not displaying Events

Posted: February 13, 2018 at 3:49 pm


cedaly1968

February 13, 2018 at 3:49 pm

The permalink is set to https://tbgmarketing.com/event/

I am able to display the events just fine with the shortcodes (when using Visual Composer the shortcode category needs to be enclosed in “category” or the shortcode will not work). When I click the button to view the details of the event, the Event does not show on the permalink. There is no page “event” for my site – to I need to create when or is that simply part of the permalink.

Listing of Events: https://tbgmarketing.com/workshops-webinars-events/

Event View: https://tbgmarketing.com/event/wordpress-workshop/


Tony

  • Support Staff

February 14, 2018 at 2:00 am

Hi there,

This is happening because you have the event slug set to ‘event’, which is the same as the singular slug.

If you go to Event Espresso -> Events -> Templates

Change the ‘Event Slug’ to ‘events’ (or anything other than ‘event’) and save the settings.

Navigate to Dashboard -> Permalinks to refresh your permalinks and then test
https://tbgmarketing.com/events/wordpress-workshop/

You event details should now load.


cedaly1968

February 14, 2018 at 6:53 am

It happens with events too – it’s why we changed it to event. We thought changing it to event would allow us to see the single detailed view of the Event. I checked to see if we have a page or post called events and we do not. Regardless of the slug, it still does not show the detail. I changed the slug back to events and refreshed the permalinks by saving them again and still does not show. I cleared browser cache and it does not show. I also tried a clear browser in Safari and the Detail Event does not show.

I tried refreshing Permalinks – I wonder if WordPress does not refresh the links if you do not actually change the permalink settings. Hmm?? That could be it but I really don’t want to impact all of my content that way.

https://tbgmarketing.com/events/wordpress-workshop/

Thanks for your help here… we had this EXACT same problem with The Events Calendar (that plus their plugin had an error that bled warnings every 5 seconds and I could never get them to fix it).

-C. Daly


Tony

  • Support Staff

February 14, 2018 at 9:31 am

I tried refreshing Permalinks – I wonder if WordPress does not refresh the links if you do not actually change the permalink settings. Hmm?? That could be it but I really don’t want to impact all of my content that way.

Just visiting the permalink setting page without doing anything else will flush your permalinks.

Thanks for your help here… we had this EXACT same problem with The Events Calendar (that plus their plugin had an error that bled warnings every 5 seconds and I could never get them to fix it).

It almost sounds like something else is using the events slug and overriding the output, but looking at the html markup on the link above it correctly shows the EE post type.

Can you do a quick test using the Theme Test Drive plugin, activate a default theme (twentyseventeen for example) and view the event then, does it show the content?

(Theme test drive allows you to switch to another theme as an admin and not affect your site visitors)


cedaly1968

February 14, 2018 at 2:51 pm

Interesting – it appears to be the theme blocking the slug. Any thoughts on how to correct that? Good call – you’ve done this before I think!!!!


Josh

  • Support Staff

February 14, 2018 at 3:19 pm

The theme may have a setting that lets you change its events slug, or you could use a completely different slug for Event Espresso’s slug option, for example setting the slug option to upcoming-events would avoid the conflict.


cedaly1968

February 15, 2018 at 6:25 am

https://tbgmarketing.com/upcoming-events/wordpress-workshop/

No bueno… there is something in the theme preventing this. Have to ask the designer.


Josh

  • Support Staff

February 15, 2018 at 6:42 am

If the theme designer can’t fix the theme, we’ll be more than happy to take a look at the theme’s code and point you in the right direction if there’s a way we can download the theme.


cedaly1968

February 21, 2018 at 6:21 pm

Have not heard back from the theme designers yet. I did switch the theme to Twenty Seventeen and the slugs worked just fine. Not sure where to go from here…


Tony

  • Support Staff

February 22, 2018 at 2:06 am

If you can host the theme’s zip file somewhere (dropbox for example) and post the link we can use to download it then we can take a look at the code to see what is happening.


cedaly1968

March 5, 2018 at 6:53 am

Hey Tony,

Thanks for the help, I have the theme loaded to dropbox, have not been able to get the support from HB Themes to get this corrected. Do you have an email I can use to share the file with you? Thanks again…


Josh

  • Support Staff

March 5, 2018 at 10:48 am

You can post the link to download if you go into your Dropbox and copy the public link to the zip file. The reason we can’t use email to share the file is because the theme files are usually too large to receive as an attachment.


cedaly1968

March 5, 2018 at 12:19 pm

Here you go – I always forget I can make links in Dropbox…

https://www.dropbox.com/s/iottm06lqc1eqm7/highend-ultimate-multi-purpose-wordpress-theme-theme-files.zip?dl=0


Josh

  • Support Staff

March 5, 2018 at 12:52 pm

OK thank you, this helps. This looks like a page template issue. Can you go to edit the event, then look for the “Page Template” box and switch from the “Scrolling Presentation” template to the “Default” template, then click the Update button?


cedaly1968

March 5, 2018 at 1:40 pm

That worked – I will work on the display now. The image is showing the URL but that is probably Visual COmposer doing that. Thanks for your help. I would not have thought to look there.


Josh

  • Support Staff

March 5, 2018 at 2:34 pm

That’s actually caused by a few places in the theme’s code where they incorrectly use the_title(). Here’s how that can be fixed:

1) open up the theme’s includes/single-featured-format.php and on the lines of code starting on line 204 change from:

<div class="featured-image">
<a data-title="<?php the_title(); ?>" href="<?php echo $full_image[0]; ?>" rel="prettyPhoto">
<img itemprop="image" src="<?php echo $image['url']; ?>" alt="<?php the_title(); ?>" title="<?php the_title(); ?>"/>

change that to:

<div class="featured-image">
<a data-title="<?php the_title_attribute(); ?>" href="<?php echo $full_image[0]; ?>" rel="prettyPhoto">
<img itemprop="image" src="<?php echo $image['url']; ?>" alt="<?php the_title_attribute(); ?>" title="<?php the_title_attribute(); ?>"/>


cedaly1968

March 7, 2018 at 1:41 pm

Thanks for your help – I got everything fixed and we are getting to work on our Webinars and Workshops. thanks much!!!


Josh

  • Support Staff

March 7, 2018 at 2:03 pm

Awesome!

The support post ‘Permalink is not displaying Events’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 8 months, 1 week ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[i]
[i]