Support

Home Forums Event Espresso Premium PDF Receipt

PDF Receipt

Posted: March 16, 2016 at 2:58 pm


Christian Rogers

March 16, 2016 at 2:58 pm

Hello,
I have been trying to launch our registration system. Originally, I could complete a registration process and click to view the receipt. Whenever I went to download a PDF version, it downloaded with no formatting or images.

I read up on the issue on the forum and I found I needed to turn fopen() to on the server. I did this and now I cannot even click to view the receipt at all. I’m also not receiving an email from the transaction. Any help would be appreciated.

Chris


Josh

  • Support Staff

March 16, 2016 at 4:22 pm

Hi Chris,

May I ask what method was used to turn fopen() on? Did it involve editing an .htacess file? If so, if you revert the change, does the receipt function again?


Christian Rogers

March 17, 2016 at 6:59 am

Hi Josh,
I edited the php.ini file through the server host dashboard. If I turn fopen() on, I cannot even get to the html receipt. If I turn it off, I can get to the html receipt but when I download the PDF, I get no images or formatting. I’ve tried it a few times.


Tony

  • Support Staff

March 17, 2016 at 7:54 am

Hi Christian,

What exact changes are you making within php.ini please?

Is it allow_url_fopen=On?


Christian Rogers

March 17, 2016 at 7:56 am

Hi Tony,

Yes, sir. I am just changing allow_url from off to on


Tony

  • Support Staff

March 17, 2016 at 8:05 am

allow_url or allow_url_fopen?

The code I posed above should be the only change needed to fix the images on the PDF.


Christian Rogers

March 17, 2016 at 8:09 am

Tony,
My apologize for the confusion. I am changing allow_url_fopen = off to allow_url_fopen = on. I cannot even get to the PDF now, as the HTML receipt will not load.


Tony

  • Support Staff

March 17, 2016 at 8:14 am

If you enable WP_DEBUG and retry does it show any error messages?

I’m guessing it’ll show max_execution_time reached but hopefully it’ll also show something a little more useful.


Christian Rogers

March 17, 2016 at 9:32 am

Hi Tony,

Strange but I am not receiving that error. It seems that now whenever fopen() is on, the website hangs entirely and I get a database error. I’m using PHP 5.3. Needless, to say I have not been too happy with this server my client has chosen. Here is what I am getting on the log file . . .

[17-Mar-2016 15:02:06 UTC] PHP Warning:  getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:06 UTC] PHP Warning:  getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: no suitable wrapper could be found in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:09 UTC] PHP Warning:  getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:09 UTC] PHP Warning:  getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: no suitable wrapper could be found in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:12 UTC] PHP Warning:  getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:12 UTC] PHP Warning:  getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: no suitable wrapper could be found in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:14 UTC] PHP Warning:  getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:02:14 UTC] PHP Warning:  getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: no suitable wrapper could be found in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:04:17 UTC] PHP Warning:  getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: Connection timed out in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:05:17 UTC] PHP Warning:  mysql_connect(): User wrdblduoAbH already has more than 'max_user_connections' active connections in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-includes/wp-db.php on line 1518
[17-Mar-2016 15:05:19 UTC] PHP Warning:  getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: Connection timed out in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 318
[17-Mar-2016 15:05:41 UTC] PHP Notice:  wp_htmledit_pre is <strong>deprecated</strong> since version 4.3! Use format_for_editor() instead. in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-includes/functions.php on line 3573
[17-Mar-2016 15:05:41 UTC] PHP Notice:  wp_htmledit_pre is <strong>deprecated</strong> since version 4.3! Use format_for_editor() instead. in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-includes/functions.php on line 3573
[17-Mar-2016 15:05:51 UTC] PHP Warning:  mysql_connect(): User wrdblduoAbH already has more than 'max_user_connections' active connections in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-includes/wp-db.php on line 1518
[17-Mar-2016 15:06:13 UTC] PHP Warning:  mysql_connect(): User wrdblduoAbH already has more than 'max_user_connections' active connections in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-includes/wp-db.php on line 1518
[17-Mar-2016 15:06:17 UTC] PHP Warning:  mysql_connect(): User wrdblduoAbH already has more than 'max_user_connections' active connections in /hermes/bosnaweb04a/b1131/ipw.greatsem/public_html/newsite/wp-includes/wp-db.php on line 1518


Tony

  • Support Staff

March 17, 2016 at 9:53 am

Hi Chris,

In short, you need to contact your host and possibly move servers if they are not willing to help with this.

getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0

I’m guessing this was being thrown before you change allow_url_fopen?

getimagesize(http://www.greatseminarsandbooks.com/wp-content/uploads/2013/01/logo.png): failed to open stream: Connection timed

Something is blocking the request, your host should be able to provide further details on this. That image loads fine within the browser, so its something server related.

mysql_connect(): User wrdblduoAbH already has more than ‘max_user_connections’ active connections

This is common on shared hosting and happens when the host has the max_user_connections set to low. You’ll run into this problem more and more as traffic increases to your site, I’m assuming your host has this set to a low number (10-20), 10 was the limit set when we saw this previously. You’ll need to discuss this with you host and up that limit, if they refuse you’ll need to move hosts.

I would raise all 3 of these issues with the hosting provider and see what feedback they can provide as the issue is with the server setup.

The support post ‘PDF Receipt’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 3 years, 8 months ago ago

Topic Tags

Tagged: , ,

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.