Support

Home Forums Event Espresso Premium Paypal IPN with Sandbox doesn't work all the time.

Paypal IPN with Sandbox doesn't work all the time.

Posted: August 25, 2012 at 3:48 pm


Thao

August 25, 2012 at 3:48 pm

Hello,
I need an advice.

I tested the Paypal gateway few days ago by using the Sandbox and the IPN worked perfectly.
I tested again today (I made some custom changes that I think I wouldn’t affect the gateway) and the IPN is never called.

To troubleshoot this, I temporarily renamed my custom add-on files and also tried using the IPN simulator in the sandbox by copying/pasting the notify_url that has been dumped in developer mode and it works.

Is there any chance that sometimes the Paypal sandbox doesn’t work?

If the IPN simulator works, could I rely on this instead?

Thanks in advance.


Sidney Harrell

August 25, 2012 at 10:45 pm

If the IPN Simulator is working, then the next thing I would check would be the logs. There is an option under General Settings to activate “full logging”. This will record all requests and request variables coming into the site. Under wp-content/uploads/espresso/logs, you will see the file containing the logging output.


Thao

August 25, 2012 at 11:02 pm

The full logging is always on. There is nothing in the paypal.ipn_results.log (so I know that the IPN transaction is never called).
And the espresso_log.txt doesn’t show anything abnormal.
It was working few days ago.
Let me know if you have any other troubleshooting tip.


Thao

August 26, 2012 at 1:35 pm

I created a test client. The _xclick command makes Paypal send the IPN. the _cart one doesn’t.
I think there is a temporary problem with Paypal (I hope it’s just this)

The support post ‘Paypal IPN with Sandbox doesn't work all the time.’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso