Support

Home Forums Event Espresso Premium Payments not processing after updates

Payments not processing after updates

Posted: May 5, 2016 at 6:11 am


Akseli Olavi Ahopelto

May 5, 2016 at 6:11 am

Hello,
We’ve run into a very serious issue on our site. It seems that EE has stopped processing payments coming from out RedSys payment gateway.
Accepted/Declined payment status is not being passed on to EE, so we have to manually check each credit card payment manually.
In addition, when checking payment logs in EE, we get the following inconsistencies:

IPN Details

Payment list

All of the payments are registered as Cash when in reality they are all RedSys payments. Also, the TXN ID is being repeated, as you can see.

Thanks for your help, if you need any additional information, please let me know. This is extremely urgent as our business relies on processing these payments.


Tony

  • Support Staff

May 5, 2016 at 7:16 am

Hi there,

The RedSys payment method is not a payment method we have developed (I’m assuming you built this yourself?) and so not something we can provide support for as we have no idea how it was built.

Which version number did you update from and to?

I’ll double check with our developers if we have made any changes to how the payment gateways are handled between those versions although this looks like an issue with the payment method itself rather than EE.

Do you have any caching enabled on the site/server?


Akseli Olavi Ahopelto

May 5, 2016 at 12:07 pm

The payment gateway was build by an external developer to handle transactions with a large platform for online payments used by most Spanish banks.
I’ll attach a link to a zipper version of the plugin below so you can take a look at the code if you’d like to understand the workings better, but it seems like everything is quite standard.
Thank you!

RedSys Payments Gateway Plugin


Akseli Olavi Ahopelto

May 5, 2016 at 12:09 pm

We believe the issues started appearing with version 4.8.41p. We are currently running the latest version.


Josh

  • Support Staff

May 5, 2016 at 3:45 pm

Hi there,

It will be best to contact the developer of the gateway add-on for support in this case.


Akseli Olavi Ahopelto

May 9, 2016 at 6:36 pm

Hello, I understand that you do not provide direct support for 3rd party gateways but it would be great if you could provide a little insight to find the source of the problem.
I just setup a clean Ubuntu VPS with the LAMP stack, a clean install of WordPress with only EventEspresso and the RedSys payment gateway. The issue still appears exactly as on our production server, so this rules out any issues/changes that could have appeared in our production environment.
Is there any way that your programmers could provide some information on what changes have been made to IPN and payment processing in general in the last few updates?
Although it’s great to see EE grow and evolve quickly, it seems a bit odd that ‘maintenance updates’ (minor-version changes) could break something as important as payments. This could be expected from major-version updates with some more warning to users.
Anyway, thank you for your time, any help you could provide would be greatly appreciated!


Josh

  • Support Staff

May 9, 2016 at 9:07 pm

I checked and it turns out there hasn’t been much as far as changes go to the IPN or payment processing in general in the last few updates. Along with that, the gateways developed and supported by Event Espresso haven’t needed to be updated for some time.


Akseli Olavi Ahopelto

May 9, 2016 at 9:11 pm

Thanks for the update. I guess we’ll have to start to troubleshoot directly with the bank seeing as the issue isn’t coming from any changes on the EE or gateway side.
Thank you!


Josh

  • Support Staff

May 9, 2016 at 9:13 pm

It could be a bug in the custom gateway, and the developer may be able to verify whether that’s the case.

The support post ‘Payments not processing after updates’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 3 years, 5 months ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!