Home Forums Pre-Sales [payment_url] not working properly

[payment_url] not working properly

Posted: September 15, 2012 at 2:39 pm

Josh Maynard

September 15, 2012 at 2:39 pm

Hi there, I’m having some issues getting the [payment_url] shortcode to work. My wordpress site is installed in a subdirectory (called wordpress). In the confirmation email the above shortcode produces this url: The above url would work perfectly if it didin’t point to the wordpress subdirectory. Meaning that works. I’m not sure sure what the issue is. I’ve tried a number of solutions– editing my .htaccess file, reinstalling EE, reinstalling wordpress etc. w/ no luck. Let me know if you have any ideas. I love the plugin! It’s exactly what I was looking for and works wonderfully minus the above issue. Cheers, Josh

Sidney Harrell

September 16, 2012 at 11:47 pm

Hey Josh,
It looks like the link to the payment page in the confirmation emails is being generated on line 276 of includes/functions/email.php:

$payment_url = get_option('siteurl') . "/?page_id=" . $org_options['return_url'] . "&r_id=" . $data->attendee->registration_id;

whereas in the data being sent to paypal for the return url is using the home_url() function, instead of the get_option(‘siteurl’).
Try changing that line 276 of email.php to be:

$payment_url = home_url() . "/?page_id=" . $org_options['return_url'] . "&r_id=" . $data->attendee->registration_id;

Can you check what your siteurl is set to in your WordPress general settings?

Josh Maynard

September 17, 2012 at 10:06 am

Thank you so much! It works perfectly now!

The site url is:
Wordpress url:

The support post ‘[payment_url] not working properly’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso