Support

Home Forums Event Espresso Premium Payment Status Incorrectly Reads Completed

Payment Status Incorrectly Reads Completed

Posted: February 11, 2018 at 11:54 pm


J

February 11, 2018 at 11:54 pm

Hello all

We have the latest version of EE3. When attendees are registering for an event, but not paying, the payment status incorrectly records that payment has been completed. I have checked the general settings – that is set to “incomplete (default”). The event specific settings are on “no change”. Would be grateful for your help asap.
Regards, Joe


Tony

  • Support Staff

February 12, 2018 at 5:01 am

Hi Joe,

Is this happening on every registration? I’ve just ran a registration on your event and stopped at the payment options, does that display as complete?

If its happening on specific registrations, had that user made multiple registrations?

I also notice you’ve removed the ‘Complete your registration’ link from the Invoice payment method:

Your site – http://take.ms/E1b5O
Mine – http://take.ms/ecG10

That link is important as it closes the registrant session, can I ask why it’s been removed on your site?


J

February 12, 2018 at 8:51 pm

Hi Tony

The error doesn’t seem to happen each time. The single registration test you did shows “Pending”, the multiple test you did actually shows “Refund” – so odd. We had a few single registrations prior that incorrectly show “Completed”.

To be honest, I wasn’t aware that the “Complete your registration link” had been removed (!) – looks like this was excluded during the development process, unless I can activate it using settings (though can’t see this)?

Regards
Joe


J

February 12, 2018 at 8:55 pm

PS: Is there an easy way to change the text in the complete your registration box (ie the box headed “Attention”)


J

February 12, 2018 at 9:50 pm

Hi Tony – I have redeemed a token we had for priority support (hope this went through – I did not seem to get a confirmation message). Joe


Josh

  • Support Staff

February 13, 2018 at 7:00 am

Hi Joe,

We received your request for priority support and there will be an email reply.


J

February 16, 2018 at 1:41 pm

Hi All – just following up to see if you have had any luck getting to the bottom of why this is happening. Joe


Josh

  • Support Staff

February 16, 2018 at 2:02 pm

Hi Joe,

This type of thing doesn’t actually involve luck, it really requires information and I’m afraid we have very little information to go on.

If I were to venture a guess, I’d say the code in the custom invoice template.php file (starting on line 64 and ending on line 76) might be causing some issues related to the payment status. That particular block of code is commented out in the core version of the same template. I’d advise doing the same for the custom template.


J

February 16, 2018 at 2:40 pm

Thanks Josh

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  J 3 days, 8 hours ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!