Support

Home Forums Event Espresso Premium Payment settings not visible on Mac

Payment settings not visible on Mac

Posted: January 11, 2013 at 5:09 am


clewis

January 11, 2013 at 5:09 am

My payment settings are showing as a menu on the right of my screen and I cannot see the options. Also the invoice setting shows the payment as 0.00 to pay…. This is urgent as my client has to advertise the event today!!!

If you give me an email address I can email you some screenshots.


clewis

January 11, 2013 at 5:52 am

It appears it views the same on my PC all in the right widget and cut off text????? Still shows amount due on Invoice as 0.00


Josh

  • Support Staff

January 11, 2013 at 8:32 am

Hi there,

There are a few possible causes to these issues. You can rules these out one by one:

1) A theme conflict. You can rule this out by temporarily switching to the default WordPress theme.

2) A plugin conflict. You can rule this out by temporarily deactivating any other installed WordPress plugins.

3) You have the latest version of Event Espresso installed, but there are add-ons that need to be updated. You can check for the latest versions of the add-ons on your account page.

4) There are old files in either of these two locations: /wp-content/uploads/espresso/templates and/or /wp-content/uploads/espresso/gateways. You can log into the server via FTP and check for files there and rename the directories so the current plugin’s files will not get overridden.

5) The server doesn’t handle the way WP compresses the admin JavaScript files. You might try disabling JavaScript concatenation for the WordPress admin to see if that makes a difference:

http://codex.wordpress.org/Editing_wp-config.php#Disable_Javascript_Concatenation

You can use an FTP client and a text editor to access and add this line to the site’s wp-config.php file:
define('CONCATENATE_SCRIPTS', false);


clewis

January 14, 2013 at 12:26 am

Hi Josh,

I am going through your list step by step, by the way the payment settings are not showing up since I did the update for Event Espresso – 3.1.29.1P on 2 January 2013.

I have added the text define(‘CONCATENATE_SCRIPTS’, false); to the wp-config.php file at the payment gateways are now visible!!

Thanks a million will test and let you know if all is working.

Take care,
Cindy


clewis

January 14, 2013 at 12:30 am

Using the “Invoice” gateway and total due is still 0.00……


clewis

January 14, 2013 at 12:46 am

Client is not receiving notifications of registrations via email…. I have used myself as a tester and I have received a registration confirmation email which contains the payment details on it anyway…. but if the person registering needs an invoice it will show that they ow 0.00….


clewis

January 14, 2013 at 2:14 am

In the registration email the amount owing also shows 0.00 so the system is not calculating the costs…


Josh

  • Support Staff

January 14, 2013 at 11:26 am

Did you check for files in either of these locations:

/wp-content/uploads/espresso/templates

and

/wp-content/uploads/espresso/gateways


clewis

January 15, 2013 at 6:47 am

Hi Josh,

Thanks for your response, I tried changing the directory names and got the following error:

Fatal error: Cannot redeclare event_espresso_2checkout_payment_settings() (previously declared in /home/edithunl/public_html/wp-content/uploads/espresso/gateways/2checkout Apr 12/settings.php:4) in /home/edithunl/public_html/wp-content/uploads/espresso/gateways/2checkout/settings.php on line 78

I then reloaded the updated event espresso which crashed the site, so I had to remove it and reload again and now back to square one with the above error…. I am going to rename the directories back to their original name and see what happens…

My client is already registering people for the event and it now shows that the event costs 0.00 which is a huge problem… your quick assistance would be greatly appreciated :o)


clewis

January 15, 2013 at 7:24 am

Hi Josh,

I replaced the directories in:

/wp-content/uploads/espresso/gateways

with the directories from the newest version and all is now working :0

Thanks!


Josh

  • Support Staff

January 15, 2013 at 8:22 am

Hi there,

You can safely remove the files from /wp-content/uploads/espresso/gateways by following these steps:

1) Deactivate all payment options in Event Espresso>Payment settings
2) Remove the files from /wp-content/uploads/espresso/gateways
3) After removing the files from the /uploads directory, you can reactivate the payment options.

If you leave the files in /wp-content/uploads/espresso/gateways, each time you update to a new version of Event Espresso, you’ll likely run into this again if there are any changes to the gateway files.


clewis

January 16, 2013 at 1:03 am

Thanks Josh,
All is resolved. I will keep the above in mind when I do an update in the future.
Thanks for all you help.

The support post ‘Payment settings not visible on Mac’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso