Home Forums Event Espresso Premium Payment screen – lots of empty space

Payment screen – lots of empty space

Posted: June 28, 2013 at 1:42 pm

Mike Gruszczynski

June 28, 2013 at 1:42 pm

I just today upgraded from the free version to the premium version. The Payment screen has a lot of empty space above the paypal link. For some reason, the Paypal button image does not show either and I cant seem to upload a new image for it on the Payment setup screen. If I recall, all this worked out-of-the-box in the free version. Was there a step I could have missed when upgrading?


June 28, 2013 at 1:53 pm

Hi Mike,

The image issue can happen sometimes when upgrading from free to premium.

The insert image button isnt working, apologies for that, its fixed in the next version, you can manually change the URL in that PayPal Button Image field to this


Where XXXXX is your site url and if needed installation folder, eg or

Regarding the spaces, I would need a link to your site to be certain but usually it is a result of the theme adding in extra spaces/css to the hidden inputs on the payment screen. Normally a little CSS can resolve that. (You can double check this by temporarily swapping to an alternative theme such as TwentyTwelve, the gaps shouldnt appear).

Mike Gruszczynski

June 28, 2013 at 2:05 pm

where can I send details so they dont show up on the forum?


June 30, 2013 at 11:16 pm


You can send the details via this form

I shouldnt need the actual login details though, just the site url. Did you get the PayPal button working? If not provide login details and I’ll check that out for you.

Mike Gruszczynski

July 1, 2013 at 9:08 am

I did get the Paypal button working. The URL you sent should not have the version number in the event_espresso folder. I found it when I removed the version number.

I found that the extra space is coming from breaks inserted by the theme or WordPress. I tried wrapping the necessary shortcodes with [raw] and [/raw] to no avail. I then went into the code (PaymentGateway.php ) to insert [raw] and [/raw] thru the do_shortcode mechanism. When I saved the file, my Admin screen went blank. I’m still trying to figure out what I can do at this point.


  • Support Staff

July 1, 2013 at 11:21 am

Hi Mike,

You can revert the changes that were made to PaymentGateway.php and contact the theme developer and ask them where in the theme it’s removing the standard WP auto-formatting functions and adding its own. It may be something as simple as removing the theme’s autoformat functions -or- adding a custom function to remove them only on the Event Espresso pages.

Mike Gruszczynski

July 2, 2013 at 3:49 pm

I tried to put the [raw] [espresso_events] [/raw] code to no avail. When that is done it just shows the words [espresso_events] on the page and not the actual events. The theme developers indicated how to turn things off within the theme, but still the same result.
Here are the site specifics

The problem is on the payments page. If you need admin, I can send under separate cover


  • Support Staff

July 2, 2013 at 10:08 pm

Hi Mike,

The problem is the theme is adding a br tag for each new line in the PHP of the payment page (which are the hidden inputs in this case).

If the theme author cannot fix this, then I can suggest hiding the extra br tags with CSS like this:

#payment-options-dv br {
display: none;

There’s a video that you can watch (and possibly share with the theme’s developer) that explains the root issue in more detail and how to fix it:

The support post ‘Payment screen – lots of empty space’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso