Support

Home Forums Event Espresso Premium Payment Gateway Issues

Payment Gateway Issues

Posted: September 26, 2012 at 4:40 pm


Ashlie

September 26, 2012 at 4:40 pm

Can someone tell me if there was an error with the latest update? I cannot get my payment page to show correctly and my payment gateway (first data) is no longer working. I keep getting error messages and it’s not with the first data side, I have already spoken with them.


Seth Shoultes

  • Support Staff

September 26, 2012 at 4:47 pm

What are the errors?


Seth Shoultes

  • Support Staff

September 26, 2012 at 4:49 pm

What version were you using before? have you tried re-saving your gateway settings? Have you checked the error logs on your server?

Also, have you made sure there are no gateway files in your /wp-content/uploads/espresso/gateways folder?


Ashlie

September 26, 2012 at 5:01 pm

Hi Seth! I’ll have to send you a picture. I’ve tried to open the page in both Firefox and Chrome and it looks odd. So the other issue with the error is that it’s telling me the enter image description here

enter image description here


Ashlie

September 26, 2012 at 5:06 pm

I just tried to update the gateway settings…same error

“Also, have you made sure there are no gateway files in your /wp-content/uploads/espresso/gateways folder?”
This could be the problem. I see files in the folder but which ones are you saying i need to remove?


Sidney Harrell

September 26, 2012 at 5:31 pm

Rename the wp-content/uploads/espresso/gateways folder to
wp-content/uploads/espresso/OLDgateways
You may have to then go to your gateways settings page and deactivate / reactivate any gateways that you had active.


Seth Shoultes

  • Support Staff

September 26, 2012 at 5:35 pm

You may need to remove, or actually just rename, the entire folder. Also, I think Firstdata changed a bunch of stuff earlier this year and we had to update the Firstdata gateway files to work with their changes. So maybe that is a problem.

Also, were you using Firstdata when they required the .pem file? If so, that may be in your gateways directory. So you should definitely save that file somewhere if it is there. But I am not absolutely sure that Firstdata still uses that or not.


Ashlie

September 26, 2012 at 5:46 pm

Thanks Sidney! Changing the file to OLDgateways fixed the way the payment page was showing.

Now I still need to get the other issue fixed.

Seth I am using the new e4 and was actually in contact with Chris a few months ago with the FirstData issue came about as I think I was the first one using Event Espresso that was using the e4. I’ll let Chris know that something is going on with it again. For now I’ll go back to using paypal until it’s fixed. Thanks for trying to help though!


Sidney Harrell

September 26, 2012 at 6:59 pm

Hey Ashlie,
The Firstdata e4 gateway can be a bit tricky. You have to log into the web interface for your e4 account and set up your site as a “payment page”, then use the identifier they give you for your “payment page” in the event espresso e4 settings. Let me know if you have any more problems with it.


Ashlie

September 26, 2012 at 7:15 pm

Yep, I’ve been using the gateway with no problem for a few months until now. I’ve contacted Chris Reynolds to see if he can look into the problem. I’m sure with it being so late I won’t hear from him until tomorrow which is ok. Thanks for trying though.

The support post ‘Payment Gateway Issues’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!