Support

Home Forums Event Espresso Premium Payment Declined

Payment Declined

Posted: May 1, 2014 at 5:12 pm


sonomaschools

May 1, 2014 at 5:12 pm

Hello,

I am trying to test the plugin on a site and I am getting a payment declined notice. I am using the Authorize.net AIM both in and out of test mode and not using the Authorize.net development server. There is nothing in the logs/espresso_log.txt document and no transactions are being recorded. Could this be because I am still on a development site with no SSL certificate? I am hesitant to push the site to its live state to test the plugin. Any ideas?

THANKS SO MUCH!

http://svgreatschools.com


sonomaschools

May 1, 2014 at 5:22 pm

WordPress Version:
3.9
PHP Version:
5.3.28
MySQL Version:
5.1.68
Event Espresso Version:
4.2.3.reg
WordPress Address (URL):
http://svgreatschools.com
Site address (URL):
http://svgreatschools.com


Lorenzo Orlando Caum

  • Support Staff

May 1, 2014 at 5:24 pm

Hello,

If you login to your live Authorizenet account, you should be seeing more information on why the transactions are being declined.

With that mentioned, I would also take the time to regenerate your transaction key for Authorizenet and update that into Event Espresso payment settings. Then double-check to ensure that there is not extra spacing before or after the credentials as this could cause the transactions to fail.

Also, we do recommend having an SSL certificate to process the transactions.


Lorenzo


sonomaschools

May 1, 2014 at 5:35 pm

How do i regenerate the transaction key? I can’t seem to find info about that anywhere…


sonomaschools

May 1, 2014 at 5:45 pm

Found it– I’m trying it now..
Thanks for your quick response!


Lorenzo Orlando Caum

  • Support Staff

May 1, 2014 at 5:52 pm

You are welcome. Let us know if that helps!


Lorenzo


sonomaschools

May 1, 2014 at 6:26 pm

Not working still.. could it have something to do with the AIM vs SIM gateway?

I have an SSL on my site that is going to be “live” but am on a dev site right now and trying to test the plugin. Nothing is working….


sonomaschools

May 1, 2014 at 7:01 pm

Hello?!

Could this be a conflict with anything else that you know of?

I would like some support, or a full refund please!


Lorenzo Orlando Caum

  • Support Staff

May 1, 2014 at 7:29 pm

Hello,

You can register for a test account here:

https://developer.authorize.net/sandbox/

Then move those credentials into place for the Authorizenet Aim payment settings in Event Espresso and be sure to turn the development/sandbox option & test transaction on.

It should process with your test credentials and if it does, then there is an issue with your other Authorizenet account.


Lorenzo


sonomaschools

May 2, 2014 at 12:05 pm

So that worked on the development server.

But no transactions are going through using my auth.net live account.

I’ve also tried doing a test in the auth.net test account mode and regenerated my auth.net key 4 times.

I just got off the phone with Auth.net, and they can’t seem to see a problem on their side, the transaction is not making it off of my site.

Are there any other things that could be happening?

It’s strange that the payment is being declined but no errors are being reported…
Also, the person I spoke with @ auth.net is wondering if there could be something blocking the proper gateway URL?

He forwarded me to this:
https://support.authorize.net/authkb/index?page=content&id=A415&actp=LIST_POPULAR

HELP!!!!


Lorenzo Orlando Caum

  • Support Staff

May 2, 2014 at 12:49 pm

Declined is the default status if a payment fails.

Since it works with a different set of credentials, then there is an issue with your account or the wrong credentials are in use.

Are you using your API Login ID?

This is different than the login for your Authorizenet account.


Lorenzo


sonomaschools

May 2, 2014 at 12:54 pm

Yes. I am using my API Login ID. Which I have re-entered manually 6 different times.
I’m not sure what an issue with the account would be- I was on the phone with Authorize.net for an hour and didn’t hear anything that could be “wrong” from that end. Is there a way to see the error log so we can understand what is happening? And why the payment is failing? I’ve also opened a premium support token and am waiting to hear back on that. Is there a way I can talk to someone on the phone about this? I’ve been trying everything I can think of….


sonomaschools

May 2, 2014 at 2:18 pm

Hello…
I have not heard from anyone about this issue.
Just checking in to make sure something is happening with your team….

I’m in need of some assistance ASAP!

Thanks so much


Josh

  • Support Staff

May 2, 2014 at 3:27 pm

Hi Laura,

I’m sorry to hear that you’re having so much trouble getting payments up and running. Can you check to see if there’s a firewall in place on the server that’s potentially blocking Auth.net’s live server at https://secure.authorize.net/ ? Port 443 needs to be open as well. From reading over this thread, it looks like there is no issue at all with connecting to Auth.net’s development server.

If you can re-submit the redeem a support token form and be sure to include FTP credentials this time support staff will be able to investigate the transaction logs. In Event Espresso 4 the transaction response is stored in the database.

The support post ‘Payment Declined’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 5 years, 6 months ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.