Support

Home Forums Pre-Releases Payment calculation bug EE 4.5 b24

Payment calculation bug EE 4.5 b24

Posted: November 25, 2014 at 4:32 am


Magonc Alapitvany

November 25, 2014 at 4:32 am

Hi! It seems that there is some kind of a calculation error with the payment amounts in EE 4.5 beta24. See this image:

The ticket price is set to 30.000 HUF, but the total is 0. Therefore the system also approves the registration without any payment.

WP version: 4.0.1
No EE addons
New installation


Dean

November 25, 2014 at 6:13 am

Hi,

In the General Settings > Countries tab, can you tell me how the currency is set up, especially the Currency Decimal Places, Currency Decimal Mark and Currency Thousands Separator.

Also can you advise how the ticket amount was typed into the ticket in the event (e.g, did you type 25 or 25,000 or 25.000 etc)


Magonc Alapitvany

November 25, 2014 at 8:46 am

Hi,

Ticket amount: I typed 30000, than after publishing it appeared as 30.000, but the strangest is now after updating the event it shows simply 30


Josh

  • Support Staff

November 25, 2014 at 11:35 am

Hi Magonc,

Can you try updating to the Event Espresso 4.5.0.27 beta that’s available for the pre-release channel?

There were some more recent fixes added to the beta branch that were related to the issues you report here. I tested .27 locally and the total is calculating correctly with what appears to be the same pricing setup.


Magonc Alapitvany

November 25, 2014 at 3:44 pm

After updating, at the event the amount is constantly appears as 30.000 BUT at the transactions and payment page it still shows 0 πŸ™


Lorenzo Orlando Caum

  • Support Staff

November 25, 2014 at 8:24 pm

Hi,

Could you go to the event and re-save without making any changes?


Lorenzo


Magonc Alapitvany

November 26, 2014 at 4:21 am

I did that, still not working


Dean

November 26, 2014 at 4:45 am

Hi,

I’m concurring with Josh, the update is showing everything correctly. Can you try creating a new test event and see if the issue persists please?


Magonc Alapitvany

November 26, 2014 at 11:19 am

Creating a new event didn’t change anything, but after deleting ALL Event Espresso Tables and Data & reinstalling the b27 version, it works πŸ™‚

The support post ‘Payment calculation bug EE 4.5 b24’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso