Support

Home Forums Translations Only 1 Event Appears on main booking page

Only 1 Event Appears on main booking page

Posted: January 18, 2013 at 5:23 am


David Venn

January 18, 2013 at 5:23 am

For some reason only 1 event is appearing on the [Espresso_Events] page.
I would like all of the events to appear.

I have also attempted to set up the calendar but no dates appear – only the header…

Any suggestions?

Thanks!!


Dean

January 18, 2013 at 5:43 am

Hello,

If I am correct in assuming your site is stagemasterproductions.com then you are running an extremely old version of the plugin (3.1.21 and the latest is 3.1.29.2.P). I would recommend that you update to receive the benefit of new features, bug fixes and support.

If your licence has expired you can purchase a new one from here https://eventespresso.com/pricing/.

In answer to your question, I am going to assume that you are running WordPress 3.5 based on the javascript you have. The version of Event Espresso you have is probably just too old to run on that version as I cannot see any other obvious issues. That version was never tested on recent versions of WordPress as other versions of Event Espresso have superseded it.


David Venn

January 22, 2013 at 2:53 am

Hi Dean,

Thanks for your response. It had expired.

I have now uploaded the latest versions but for some reason still only one event will appear in the ‘list’ options. This never used to happen…

I have tried just using categories and the Events_espresso

Do you know why this might be happening?


Dean

January 22, 2013 at 3:54 am

Hi David,

Have you recently changed or updated the theme? It looks like the theme is a Themeforest product and whilst some of the developers there are excellent, we do see a lot of themes running certain code that messes with shortcodes.

You can try to wrap the main [ESPRESSO_EVENTS] shortcode in raw tags e.g.:
[raw][ESPRESSO_EVENTS][/raw]

If that doesnt work please check to see if your themes functions.php contains code similar to this http://www.wprecipes.com/disable-wordpress-automatic-formatting-on-posts-using-a-shortcode. If so either comment it out or remove it (make sure you have FTP access and/or a backup of the file).


David Venn

January 22, 2013 at 4:08 am

Hi Dean,

I just took a look and tried the raw files.

No luck.
Am I able to get someone to take a look for me?

Let me know how this could be possible.

Cheers!


Dean

January 22, 2013 at 4:36 am

Hi David,

I can take a quick look to see if I can pinpoint the issue.

Is it possible to get your login details in order to look into this? Also I will need FTP details in case I need to amend a file.

If so, please send them via https://eventespresso.com/send-login-details/

NOTE: login details need to be Admin level.


Dean

January 23, 2013 at 2:05 am

There was a few things going on here

You had a theme in your themes folder instead of in its on folder – sorted.

You had the main registration page pointing to the wrong page – sorted, it is now pointing to the whats-on-book-now page.

You had a secondary page called book now with the [ESPRESSO_EVENTS] shortcode on it – sorted (removed the shortcode)

In the end it was the template files, I renamed the template folder and the plugin is back to functionality. If you modified any files there you will need to re-look at these.

Also, I deactivated some plugins and on reactivation the InteliWISE plugin failed to work (requires a login) so sorry about that. I have left it deactivated due to it showing an error message on the front of the site.

The support post ‘Only 1 Event Appears on main booking page’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Dean 8 years, 1 month ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!