Support

Home Forums Event Espresso Premium On submitt, Why don't attendees get email.

On submitt, Why don't attendees get email.

Posted: April 12, 2018 at 9:34 pm


shooin

April 12, 2018 at 9:34 pm

So i have created a few events and made some modifications due to the fact that my events are fee for now. However what I want to happend I cant seem to get to work. lets say I want to purchase or rsvp 3 tickets. I put in 3 differnt names and email1@me.com, email2@me.com and finally email3.me.com. For what ever reason those three emails come to me: i want them to go the email1@me.com, email2@me.com and finally email3.me.com. Am I missing something or does this not work in that regard.


Josh

  • Support Staff

April 13, 2018 at 8:11 am

Hi there,

May I ask are the emails you’re getting the Event Admin emails?

There are a number of ways to set up email notifications, so if you’ve made some modifications you may need to adjust the email settings. Maybe you can post a link to the event in question so we can investigate further?


shooin

April 13, 2018 at 9:43 am

I registered four people and four emails are being sent however they all go to the same person. I guess it goes the the regisitrant and not the attnedee which is what I want.

here is a screen grab.
https://www.dropbox.com/s/3gibutv4h1n4o4x/Screenshot%202018-04-13%2011.43.49.png?dl=0

Thanks


Josh

  • Support Staff

April 13, 2018 at 9:55 am

Maybe you can post a link to the event in question so we can investigate further?


shooin

April 13, 2018 at 10:06 am

Yes.. Here is the link.

http://www.provideralliance.org/events/tpa-april-membership-meeting/

Let me know if you want credentials and I can PM to you or something.

Thanks


Josh

  • Support Staff

April 13, 2018 at 10:27 am

OK so the reason they’re not getting the email is because you’re not using the system email field for the additional attendees. Here’s a screenshot that might help clarify this:

https://slack-files.com/T02SY781D-FA6FZ5R6E-33a007ace3

The way forward will be to split the Organization question out of the Personal Information question group, then assign it to a new group. Then in the event editor, set the Primary Attendee to have the new Question Group that holds the Organization question.

Then you can check the box next to Personal Information group for the Additional Attendees, and uncheck the box next to “Attendees”.


Tony

  • Support Staff

April 13, 2018 at 10:29 am

Hi there,

It’s happening because you’ve added your own question ‘Name’ and ‘Email’ questions that you are using for the additional registrants.

EE has no idea those custom questions are additional registrant details, they are just custom questions.

It is possible to setup EE to use a custom question and have the messages system use that for the email ‘to’ field, but the better solution is use the ‘Personal Information’ question group for both the Primary registrant and the Additional registrants, so on these settings within the event – http://take.ms/1CBvc

You want the bottom ‘Personal Information’ question group checked.

Right now you have another custom question assigned to that group (‘Organization’), if you want that to only show on for the Primary registrant you create a new question group (Event Espresso -> Registration form -> Question groups) and add that question to that group. Then select that additional group on the primary registrant question group setting above.


shooin

April 13, 2018 at 10:55 am

@josh – HUH? I dont quite understand. and Tony- about the same. I am sorry forgive my ignorance. Here is what I have checked. I will try to follow along but it sounds complicated.

https://www.dropbox.com/s/16xr2suvqvwzuhz/Screenshot%202018-04-13%2012.48.53.png?dl=0

Thanks
Jason


Josh

  • Support Staff

April 13, 2018 at 11:01 am

Here’s the suggested changes from the above, annotated onto your screenshot:

https://slack-files.com/T02SY781D-FA7DJG3DL-2cc5c7c6b1


shooin

April 13, 2018 at 11:02 am

I think it was simple. Wow you guys really made this thing easy, I think i got it now. Stand by.

Thanks
Jason


shooin

April 13, 2018 at 11:10 am

off topic but hopefully quick.. where is this pulling from in the emails?
I can’t seem to find it.
THanks

https://www.dropbox.com/s/enh5va5g195n9mh/Screenshot%202018-04-13%2013.10.51.png?dl=0


shooin

April 13, 2018 at 11:14 am

It is the [EVENT_AUTHOR_EMAIL]


shooin

April 13, 2018 at 11:16 am

Never mind. I answered my own question.

Thanks


Tony

  • Support Staff

April 13, 2018 at 11:35 am

Just for any future readers, the EVENT_AUTHOR_* shortcodes pull the details from whatever user account is set as the author on the event itself – http://take.ms/KXo9O

You can either change the author to another user that has the details you want to use for the event author shortcodes or you can edit the message templates to use a different shortcode, such as CO_EMAIL, however you’ll need to edit multiple message templates and each of their contexts to change them all.

https://eventespresso.com/wiki/messages-system-working-with-message-contexts/

The support post ‘On submitt, Why don't attendees get email.’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 6 months, 1 week ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!