Support

Home Forums Event Espresso Premium On a separate request messages setting

On a separate request messages setting

Posted: October 14, 2019 at 5:22 pm


lupineart

October 14, 2019 at 5:22 pm

Hey guys,

Just working through the Automated Upmcoming Email plugin. I have this setting set to generate messages on the same request. It says to reach out to you if this is the case.

I don’t remember why it is set like this, but we worked through an issue a long time ago. We recently changed to dreamhosting VPS, so with a new host since then.

Please let me know what next steps to take…

Thanks,

Derek


Tony

  • Support Staff

October 15, 2019 at 4:07 am

Hi Derek,

Change that option to ‘On separate request’ and save.

Now add a test registration to an event and finalize (use the invoice payment method, or create a test event with a free ticket and register onto that).

Now, as soon as you have finished loading the thank you page go to Event Espresso -> Messages -> Message activity.

You should see some messages ‘queued for generation’.

Wait about 5 mins and refresh the page, do those messages change to show waiting to send, or possibly sent already?

If it does, WP_Cron and the messaging system is working fine on your site and you can leave it as is.


lupineart

October 15, 2019 at 11:33 am

Hi Tony,

This is what shows for message activity: https://www.dropbox.com/s/o7c195b09dnsylw/Screenshot%202019-10-15%2010.39.11.png?dl=0

It’s from the same test event, free ticket. The two that have no recipient were 2 separate attempted (registrations) for the setting ‘on separate request’. The top 2 were with the setting as ‘on same request’.

Please advise…

Thanks,

Derek


Josh

  • Support Staff

October 15, 2019 at 11:53 am

Hi Derek,

If you waited 5 minutes or more, then refreshed the Messages Activity page, and the Messages still say “No recipient”, then that’s a strong indication that WP_Cron is disabled for your website. You’ll need to re-enable WP_Cron or set up a suitable alternative if you want to use the Automated Upcoming Event Notifications add-on.

One way that wp_cron could have been disabled is within the site’s wp-config.php file. If you go in to review that file, and you see the following:
define('DISABLE_WP_CRON', true);

Then that’s why the Cron events aren’t running as expected. Removing the above code may solve the issue.


lupineart

October 15, 2019 at 11:58 am

Hi Josh,

I misunderstood the original instructions. I didn’t wait long enough. I just performed another test and everything seems to be working fine.

Thanks, Derek

The support post ‘On a separate request messages setting’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  lupineart 1 month ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.