Support

Home Forums Event Espresso Premium not working when save

not working when save

Posted: April 26, 2021 at 11:13 am


Charlie

April 26, 2021 at 11:13 am

Hello.

This is throwing me an error when I update.
Fatal error: Uncaught Error: Call to a member function start_date_and_time() on null in /var/www/wp-content/plugins/event-espresso-core-reg/caffeinated/admin/new/pricing/espresso_events_Pricing_Hooks.class.php:497 Stack trace: #0 /var/www/wp-content/plugins/event-espresso-core-reg/caffeinated/admin/new/pricing/espresso_events_Pricing_Hooks.class.php(283): espresso_events_Pricing_Hooks->_update_tickets(Object(EE_Event), Array, Array) #1 /var/www/wp-content/plugins/event-espresso-core-reg/admin_pages/events/Events_Admin_Page.core.php(1020): espresso_events_Pricing_Hooks->datetime_and_tickets_caf_update(Object(EE_Event), Array) #2 /var/www/wp-content/plugins/event-espresso-core-reg/core/admin/EE_Admin_Page_CPT.core.php(1013): Events_Admin_Page->_insert_update_cpt_item(6315, Object(WP_Post)) #3 /var/www/wp-includes/class-wp-hook.php(292): EE_Admin_Page_CPT->insert_update(6315, Object(WP_Post), true) #4 /var/www/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(6315, Array) #5 /var/www/wp-includes/plugin.php(484): WP_ in /var/www/wp-content/plugins/event-espresso-core-reg/caffeinated/admin/new/pricing/espresso_events_Pricing_Hooks.class.php on line 497


Tony

  • Support Staff

April 27, 2021 at 2:31 am

Hi there,

That can happen for a few reasons.

The first, is you’ve reached the max_input_vars setting on your server. How many datetimes and tickets do you have on this event?

Does it happen on every events? For example if you create a new event with a single datetime and ticket and save, does it work? (Note you may need to publish the event and then save again to confirm).

Any customizations within Event Espresso at all?


Charlie

April 29, 2021 at 9:16 am

So what we did was just finish that event and create a new one. We have migrated to a Managed wordpress in Godaddy and all the old events seems to be doing that.


Tony

  • Support Staff

April 30, 2021 at 3:30 am

That would normally be an indication that something within the migration was not done correctly as moving servers should not prevent you from editing/updating existing events if it is done correctly.

I’ve seen the above error caused by a plugin conflict, but then that would also apply to your new events. All old events not working, but new ones working fine would suggest and issue with the migration.

Does everything else work as expected within EE? Can you edit message templates etc?


Charlie

April 30, 2021 at 9:17 pm

Hi Tony,

So far everything is working fine. I advised them to create new classes instead and I tested them it seems to be working well with new classes.
Cross fingers. I’ll be constantly testing the system.
I upgraded event espresso so that should help too.
Hopefully thats the only thing that was corrupted from the migration.

Thanks I guess this is closed.

– Cecile

The support post ‘not working when save’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Do NOT follow this link or you will be banned from the site!