Home Forums Event Espresso Premium Not sending Confirmation Emails to Me

Not sending Confirmation Emails to Me

Posted: July 30, 2012 at 5:48 pm


July 30, 2012 at 5:48 pm

I just upgraded from EE to EE 3.1.25.P and when someone registers for an event, it does not send me the confirmation email. This was working fine before I upgraded. I have it set in the general settings to send to my email address.


  • Support Staff

July 31, 2012 at 8:43 am

The first thing I would check for would be if these are getting caught in a spam folder someone. I remember one user had reported that the IP address from which the emails were getting sent out was banned by his ISP, so the emails didn’t even make it into the spam folder.

Two other things you could try: Add an alternate email address (under the event options section of the event editor) and check the alternate email account to see if that one gets the email. A second option would be to route the emails through an SMTP account (eg. a gmail account) by installing and configuring the WP Mail SMTP plugin.


July 31, 2012 at 11:58 pm

After I submitted this message, A few hours later I received the confirmation email. This happened today, someone registered and I got the email, but no confirmation email from EE. A few hours later, the confirmation email form EE came through. So I guess it is more of a delay issue than not getting them.

How can I fix this delay issue?


  • Support Staff

August 1, 2012 at 7:47 am

There could be a number of issues going on with the mail server. It usually boils down to either the mailserver is overloaded (this can happen on a shared server) or something isn’t configured correctly. One option would be to contact your host and ask them to run some tests on the mailserver. Another option would be to bypass the mailserver all together and, as mentioned above, route the mail through an SMTP account with the WP Mail SMTP plugin.


August 1, 2012 at 5:49 pm

I called my hosting company and they said the email is working fine, so it must be an issue with EE. I am trying not to overload my site with plugins.. any other options? It seems like this just started when I upgraded EE.


  • Support Staff

August 1, 2012 at 6:19 pm

Event Espresso does not have a mechanism that delays sending email. Try setting up the SMTP plugin or switch hosts.


August 1, 2012 at 6:24 pm

Ok so here is what I dont get. I have the Contact 7 plugin, and that sends mail right away. When someone registers for my site, it sends mail right away, but when someone registers for an event through EE, it delays the confirmation email to me, but sends it immediately to the attendee.


  • Support Staff

August 1, 2012 at 6:36 pm

Have you tried the Smtp plugin, or tried setting the alternate email to send the reg. summary to another email account?


August 1, 2012 at 6:58 pm

I have not, because like I said above, it was working until I upgraded EE. It is an issue with EE and I don’t want to have to install yet another plugin when this should work and worked fine before upgrading.


  • Support Staff

August 2, 2012 at 9:09 am

Hi Terry,

We’d like to help you get this resolved. Can you work with us on this? I’ve tested this on 4 different servers and I receive these emails instantly. If it was an issue specific to Event Espresso, then I think it would delay for any email address sent by any mailserver.

If you can try sending the admin email notification to an alternate email address (like a gmail account) that will help rule out a conflict with the email account.

If you can, even temporarily, install and configure the WP Mail SMTP plugin to send out email through a gmail account or similar, that will help rule out any conflicts with the mailserver.

A third thing I can think of that might help is to switch the ‘use Fancy email headers’ option to not use the custom email headers.


August 2, 2012 at 4:35 pm

Interesting.. when I set the admin to a google account it works fine. The interesting thing is that we are using google apps for our mail servers.

I guess I still don’t get why it would work wiht an external google account but would be delayed with our google apps. Not to mention, none of our other mail to or from our google apps is slow, just EE mails.


  • Support Staff

August 3, 2012 at 3:53 pm

I use a google apps for domains email account for testing and there is no delay for receiving the admin registration summary for me.

In the gmail interface, there’s an option to ‘view original’. This will show all the email details. Check and compare the receive times.


September 5, 2012 at 10:25 am

I am also having this exact same issue. Confirmations are not being sent. They were working correctly on a development server where the emails were being sent to a different, normal email address, but stopped working when we went live and started using our Google Apps emails. We are also using Google Apps for our email. There has to be a connection here…

Seth Shoultes

  • Support Staff

September 5, 2012 at 7:49 pm

@Melissa you might try checking to see if your emails are getting blocked by Google. Sometimes they will block outgoing emails if they think the email is spam. You might want have your hosting company check to see if the DNS set up properly for your site and also check the email logs to see if there are any send errors.

The support post ‘Not sending Confirmation Emails to Me’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso