Support

Home Forums Event Espresso Premium I am not getting registration emails

I am not getting registration emails

Posted: March 5, 2020 at 2:17 pm


Terri Shinners

March 5, 2020 at 2:17 pm

I am using the latest version of EE and when someone registers I am not getting a notification. Checked spam and it is not going there either. Am I missing something?


Tony

  • Support Staff

March 5, 2020 at 3:01 pm

Hi there,

If you go to Event Espresso -> Messages -> Message activity

Can you see the messages listed there?

If so, what colour ‘status bar’ do they have? (The colours bar to the left of each one)


Terri Shinners

March 11, 2020 at 5:52 pm

Yes they are listed there, and the color is blue.


Josh

  • Support Staff

March 11, 2020 at 9:54 pm

Hi,

When the color is blue that means the emails were not automatically sent. If you click the double arrow icon that will manually trigger the email to be sent.

You could check your site’s Tools > Site Health page to see if scheduled tasks are working on your site. After 30 seconds does the page have a message about a failed loopback request or a failed scheduled task?


Terri Shinners

March 12, 2020 at 9:38 am

Site tools has those 2 items as passed. Client said they started working again so for now I will say this is resolved – even though we have no idea how it got resolved.


Josh

  • Support Staff

March 12, 2020 at 11:09 am

One thing it could be is the way WordPress sets up its triggers scheduled tasks (also called wp_cron). Basically the wp_cron fires after a set period of time (in the case of emails 5 minutes) and there’s a visitor on the site. If the site doesn’t get visitors more frequently than every 5 minutes there could be a delay with generating the sending emails.

So for example if someone does a registration then no visitors until the next time your client logs into the site, the client logging into the site would trigger the email generation, (which is the state when the email status is blue) then 5 minutes later + another visit later they’ll send.

There is a setting to send emails on the same request, you can change that in Event Espresso > Messages > Settings. Please note the emails need to be set to send on a separate request if you use the Automated Upcoming Event Notifications add-on.

The support post ‘I am not getting registration emails’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 2 weeks, 3 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!