Support

Home Forums Event Espresso Premium Not getting Payment Received email

Not getting Payment Received email

Posted: July 19, 2019 at 7:26 am


HC4Wb

July 19, 2019 at 7:26 am

We are receiving the Registration Approved email but not the Payment Received email. I tried to resend and still did not receive it. Checked spam and not in there either. Our setting is set to generate and send all messages on same request.


Josh

  • Support Staff

July 19, 2019 at 7:50 am

Hi,

What you could do is compare the To: fields for the Admin context. In other words check the Registration Approved template’s admin context, then check the Payment Received template’s admin context, and compare what’s in the To: fields. If they have different shortcodes there, then one of them may be going to a different email address.


HC4Wb

July 19, 2019 at 8:16 am

Checked that and noticed that Payment Received template’s admin context was blank so updated that. The issue is that the Primary Registrant is not receiving the Payment Received email, I sent a test email and I received the email, but yet when I completed the registration (tried with 2 different emails) the registrant never received the email – check in both spam folders and nothing.


Tony

  • Support Staff

July 19, 2019 at 8:39 am

When you go to Event Espresso -> Messages -> Message activity

Can you see the Payment Received emails the Primary Registrant should have received listed there with their email?


HC4Wb

July 19, 2019 at 8:53 am

Yes I see the registrants email and I tried resending from the back end in message activity but still do not receive.


Tony

  • Support Staff

July 19, 2019 at 9:04 am

Ok, and the ‘status bar’ to the left of those messages is green?

If the email is shown there with a green status bar then it means it has been correctly triggered by EE and passed over to wp_mail to do whatever your server is set up to do with it without any errors.

If the email isn’t received after that it usually means it’s been dropped by of the mail server along the way (which is outside EE’s control).

Are you using your hosts mailserver, SMTP or another service currently?

The easiest way to tell if this is happening is to use a transactional email service such as the ones listed here:

https://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

Which you basically sign up to, install their plugin and configure it and then the emails are sent through their servers. Test the email again and if it works its an issue with the mail server you used before.

The support post ‘Not getting Payment Received email’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 1 month ago ago

Topic Tags

Tagged: 

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!