Support

Home Forums Event Espresso Premium Not emailing tickets

Not emailing tickets

Posted: March 9, 2020 at 5:07 am


winetober

March 9, 2020 at 5:07 am

The email tickets stopped working during a live ticket sales period. I did not make any changes to the site during the live ticket sales, but the email ticket feature stopped working. My page is winetober.com


Tony

  • Support Staff

March 9, 2020 at 12:11 pm

Hi there,

May I ask, when you say the ’email tickets’, which specific email is that?
All emails?

If you go to Event Espresso -> Messages, can you see the emails listed there?
If so what colour ‘status bar’ (the bar to the lft of each message) do they have?


winetober

March 13, 2020 at 12:07 pm

Waiting for reply I emailed screenshots
status bar is red they are not sending
This needs to be fixed ASAP
Help fix please


Josh

  • Support Staff

March 13, 2020 at 12:35 pm

Hi,

I’m afraid we haven’t received any emails with screenshots.

If you go to test an email from one of the email Message template editors, do you receive the test? If so, it may help to go to Event Espresso > Messages > Message Settings and set the the option for emails to be sent on the same request.

If not, can you verify whether *other* emails (like a WordPress password reset email) get sent from your site?


winetober

March 15, 2020 at 6:48 am

How do you fix to make the ticket email customers after the purchase them


winetober

March 15, 2020 at 6:48 am

How do you fix to make the ticket email customers after the purchase them


Tony

  • Support Staff

March 16, 2020 at 6:02 am

Hi there,

Waiting for reply I emailed screenshots

As Josh mentioned, we haven’t had any screenshots so I don’t have any further information than what you’ve posted.

status bar is red they are not sending

A red status bar indicates that the mail server you are using is returning failed, but it doesn’t give any information as to why it failed.

How do you fix to make the ticket email customers after the purchase them

It happens automatically and if you can see them in the message activity list as you mentioned above, EE is correctly triggering them.

Can you post the screenshots you are sending to us via email here?

https://eventespresso.com/wiki/troubleshooting-checklist/#screenshots

On the messages with a red status bar, if you click on the ‘i’ icon, what message does it show?


winetober

March 16, 2020 at 6:23 am

I emailed the screen shots again. THERE IS NO WHERE TO LOAD THEM HERE!!!
I SENT EMAIL TO SALES
THIS NEEDS TO BE FIXED


Tony

  • Support Staff

March 16, 2020 at 7:39 am

I emailed the screen shots again. THERE IS NO WHERE TO LOAD THEM HERE!!!

The link I gave you above gives you multiple different methods of adding screenshots.

For example, uploading them to the media library on your site and including the link here works fine.

I SENT EMAIL TO SALES

I’ve just checked all of our mailboxes and there are no new emails.

How many images are you sending? I’ve checked all of our mailboxes and there are no new emails. If the total size of all of your images is greater than 10MB both your mail server and ours will reject them which is why I asked you to include them here.

THIS NEEDS TO BE FIXED

We are trying to help you fix this, but we can’t help without additional details.


winetober

March 16, 2020 at 7:54 am

I emailed again to sales@eventespresso.com


Tony

  • Support Staff

March 16, 2020 at 8:05 am

OK, those I received and its not just ticket emails, it’s all emails.

If you click on the icon for the top email, whats error message does it display?

Right now, it looks like your emails are correctly being triggered and generated by Event Espresso but your mail server is failing when EE passes them over to send.

Note that EE doesn’t ‘send’ emails itself, it passes them over to your server t do whatever it is set up to do with them and it’s at that point that this looks like it’s failing (meaning your server’s mail server, not Event Espresso).

Your site’s email is a Gmail email, how are you routing your site’s emails through Gmail?


winetober

March 16, 2020 at 11:31 am

My email is gmail. I do not use a mail server
The emails are going to customers and failing the are also failing copying my mailbox. How can this be fixed?


Tony

  • Support Staff

March 16, 2020 at 11:38 am

My email is gmail. I do not use a mail server

You do use a mail server, your site uses Gmails mail server.
To send emails you have to have a mail server.

The emails are going to customers and failing the are also failing copying my mailbox.

All emails are failing because the communication between your site and Gmail is failing.

How can this be fixed?

You’ll need to answer this from above:

Your site’s email is a Gmail email, how are you routing your site’s emails through Gmail?

Usually, you’ll use a plugin such as WP Mail SMTP which basically logs into your Gmail and sends the emails from your site through Gmail.

If you go to Dashboard -> Plugins can you see any plugins that list SMTP?


winetober

March 18, 2020 at 8:53 am

See how this screenshot has a TO field
https://prnt.sc/ri3tzm
On Ticket which is not emailing does NOT have TO field
https://prntscr.com/riglc3
https://prntscr.com/rigm3i


Tony

  • Support Staff

March 18, 2020 at 10:23 am

The ‘Ticket’ template, never emails.

It is a HTML message type and sits in the message system as it’s used to edit/generate the output, it is not an email message type, so it is expected not to have a ‘To’ field for that message type.

The ‘Ticket notice’ is the email containing a link to the ticket, that would have a ‘To’ field.

On Ticket which is not emailing does NOT have TO field

None of your emails are sending according to the screenshots you sent me. Which means this isn’t a ‘ticket’ issue, its an email issue. Your using Gmail to send your emails, which means you must be linking your site to Gmail somehow so to fix this, you’ll need to answer the question from my last reply:

https://eventespresso.com/topic/not-emailing-tickets/#post-309694


winetober

March 18, 2020 at 10:31 am

There is NO PROBLEM WITH MY EMAIL
The When the message is sent as not approved IT WORKS
THIS MEANS THERE IS A PROBLEM ELSEWHERE
testing with not approved WORKS.
Live ticket does not work
Is there anyone who can help I paid for service ]
Can someone help with this issue????


Tony

  • Support Staff

March 18, 2020 at 10:44 am

There is NO PROBLEM WITH MY EMAIL
The When the message is sent as not approved IT WORKS
THIS MEANS THERE IS A PROBLEM ELSEWHERE
testing with not approved WORKS.

At no point have you said this previously, nor do you screenshots show this.

All of the information you’ve given me so far shows all of your emails failing.

Heres a screenshot of your screenshot: https://monosnap.com/file/25OeL1TXwOzDrT1Leyq1j8jQwXJ4EJ

It shows your registration approve, ticket notice and payment received emails are all failing.

Live ticket does not work

Ticket, isn’t an email.

Is there anyone who can help I paid for service ]
Can someone help with this issue????

I’m trying to help you, but for some reason, you don’t want to answer the questions I ask. I can only go from the information you’ve given me so if you don’t answer the questions asked I can’t move forward.

If you sent a test email from the Registration Approved message type, does that work?

You do that in Event Espresso -> Messages -> Default message templates -> Edit Registrant -> Extra actions.

Input your email address and click test send.


winetober

March 18, 2020 at 10:48 am

No. The ticket function does not work. I am looking for the tickets to email to the person who registered.
We tested and there is no problem with my site or my email
But still no tickets are emailed.
The function to my understating is to email tickets. NO?


winetober

March 18, 2020 at 10:50 am

Should you have a direct question, ask don’t point to a page link. I don’t see any question


Tony

  • Support Staff

March 18, 2020 at 10:54 am

If you send a test email from the Registration Approved message type, does that work?

You do that in Event Espresso -> Messages -> Default message templates -> Registration Approved -> Edit Registrant -> Extra actions.

Input your email address and click test send.


winetober

March 18, 2020 at 10:56 am

no


Tony

  • Support Staff

March 18, 2020 at 11:04 am

Now the same for registration pending payment.

Does that send?


winetober

March 18, 2020 at 11:06 am

yes registration pending works


Tony

  • Support Staff

March 18, 2020 at 11:25 am

So its ‘only’ Registration Approved, Ticket Notice and Payment received that fails so far?

Compare the ‘To’ and ‘From’ fields between those and Registration Pending Paymemt, any differences?


winetober

March 18, 2020 at 11:28 am

I think I fixed this site program uses a link to website landing page
The ticket doesn’t get emailed.
Why is that? The ticket emailing would be a better idea and not cause my site to crash when 500+ people access the ticket at the same time.


Tony

  • Support Staff

March 18, 2020 at 11:33 am

I think I fixed this

Ok, great. May I ask what the problem was?

site program uses a link to website landing page
The ticket doesn’t get emailed.
Why is that?

One of the reasons for this is because we use a JavaScript library to construct the QR codes, those wouldn’t work in emails.

The ticket emailing would be a better idea and not cause my site to crash when 500+ people access the ticket at the same time.

If your site is crashing from 500 people loading the ticket, you’ll need to look into more powerful hosting as we don’t have plans to include the tickets directly within the emails at this time.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: publish

Updated by  Tony 1 week, 4 days ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!