Support

Home Forums Event Espresso Premium Not all registration and ticket emails going to customers

Not all registration and ticket emails going to customers

Posted: September 1, 2020 at 3:58 am


SteveMBragg

September 1, 2020 at 3:58 am

On my web site I have over 4,000 registrations for events. However only 3,000 or so registration emails have been sent and over 900 were stuck in the “queued for sending folder”.

This means that several attendees have not received their emails and we are getting complaints as to why this is happening.

The web site is : ntlbiologica.com/antibodytesting.

Please can you advise

Kind regards

Steve B


Tony

  • Support Staff

September 2, 2020 at 6:50 am

Hi Steve,

Can you install this plugin on the site: https://en-gb.wordpress.org/plugins/wp-crontrol/

Then go to Dashboard -> Tools -> Cron Events

Search for AHEE__EE_Messages_Scheduler, how many jobs does it find?

You should these 3 listed there:

AHEE__EE_Messages_Scheduler__sending
AHEE__EE_Messages_Scheduler__generation
AHEE__EE_Messages_Scheduler__cleanup


SteveMBragg

September 2, 2020 at 9:45 am

Hi Tony

I have done that and done the search you requested.

There is only one chron job: AHEE__EE_Messages_Scheduler__cleanup.

There are no others that are found in that search.

Steve


Tony

  • Support Staff

September 2, 2020 at 9:50 am

Ok, that’s why your messages aren’t sending.

To fix that you’ll need to temporarily de-activate Event Espresso 4 and then re-activate it.

We’ve seen this happen a couple of times but so far has been unable to narrow down what is removing the cron jobs so I can’t tell you why it happens, but the above should fix it.


SteveMBragg

September 2, 2020 at 11:19 am

That has not really helped.

After deactivatinng and reactivating I suddenly got about 50 emails of payments but there are still 967 emails stuck in the Queued folder and ticket registrations have not gone out.

Steve


Tony

  • Support Staff

September 2, 2020 at 12:01 pm

Then it has helped, it is working through the message queue.

Open up the same Cron events page you had before, does it now show the 3 events?


SteveMBragg

September 2, 2020 at 1:30 pm

Yes but it’s a constant battle now for emails coming in and out of date emails going to customers with outdated tickets and registrations!

It is all bizarre!


SteveMBragg

September 2, 2020 at 1:40 pm

It is starting to happen again. Now this evening some emails are getting stuck in the queued folder!

Steve


Tony

  • Support Staff

September 2, 2020 at 2:39 pm

Your original post implied you wanted the emails to send, the above will have fixed the message queue and started sending those emails.

So you don’t want the queued emails to send? If not you’ll need to delete them before they work through the message queue and send.

It is starting to happen again. Now this evening some emails are getting stuck in the queued folder!

May I ask how you can tell? It is expected for messages to site in the message queue waiting to send until the corn job to send them is triggered, so how are you comparing the messages to see if they are stuck?


SteveMBragg

September 2, 2020 at 2:44 pm

Tony

My original post did not imply I wanted any old outdated emails to send. It DID imply I wanted the situation sorted out so customers actually got their registrations properly.

I have now deleted old emails that have not gone.

Steve


Tony

  • Support Staff

September 2, 2020 at 2:47 pm

Ok. I guess that’s my mistake then, my apologies.


SteveMBragg

September 3, 2020 at 1:48 am

Absolutely no problem, Tony 🙂


SteveMBragg

September 8, 2020 at 5:59 am

I have to re-open this ticket.

1 in 3 people are calling us to say that they are not getting their registration details or their tickets. Emails are not going into spam or the deleted folder on their email account or email client.

Emails are NOT stuck in the Queued For Sending folder and are showing as sent in the Sent folder.

This is causing great frustration with both the customers and the staff as we are 1. receiving a lot of calls and 2. having to carry out re-sends, only for the customer to again call us to tell us that they have not had the re-sent email!

So we try again and they still do not get the mail.

This is only affecting EE as other associated emails, like medical consent forms are being set to them correctly.

Please help

Regards
Steve B


Tony

  • Support Staff

September 8, 2020 at 6:45 am

Hi Steve,

The short answer to this is to use a transactional email service:

https://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/

Switching to one of the above fixes 99% of the deliverability issues we’ve had reports of.

To explain a little more, if the emails are showing as sent within Event Espresso then the emails triggered, generated and sent as expected as far as EE is aware. If the users aren’t receiving them after that the issue is further downstream, usually meaning the mail server itself.

Event Espresso doesn’t actually ‘send’ email, it generates it and passes that to wp_mail() which basically does some of its own checking for valid headers etc and allows other plugins to hook in and change things if needed. wp_mail() then passes the email over to your server to send the email however it is set to do so.

If the email shows in Event Espresso as sent, all of the above happened with no errors and we don’t have any control over the email from there.

How are you sending emails from the site? Using your host’s mail server?


SteveMBragg

September 8, 2020 at 8:08 am

Mail is being sent via our hosts server, presumably. However as the mail is not being sent via SMTP I don’t know how the settings are.

How do we send mail from our own servier using SMTP??

Regards

Steve


Tony

  • Support Staff

September 8, 2020 at 8:11 am

Sorry, I don’t follow.

Which server would you be using to send email via SMTP?


SteveMBragg

September 8, 2020 at 10:16 am

Hi Tony

Our server of course. We would not go outside the UK or go for paid services if we can use our own mail server.

This is now sorted and we are porting all EE amils via our mail server.

Regards
Steve B


Tony

  • Support Staff

September 8, 2020 at 11:57 am

Our server of course. We would not go outside the UK or go for paid services if we can use our own mail server.

It isn’t obvious that you are hosting your own mail server and then asking for your own SMTP settings.

This is now sorted and we are porting all EE amils via our mail server.

Great! Have you confirmed if the emails are now being received by ‘problem’ users?


SteveMBragg

September 8, 2020 at 12:03 pm

Re: It isn’t obvious that you are hosting your own mail server and then asking for your own SMTP settings.

Oh OK. Again you have missread my post, or probably my request was bad. I did not ask HOW to do SMTP settings, that is kndergarten stuff. However what I DID ask was how “How do we send mail from our own server using SMTP??” – i.e. withing your plugin, but as it has no SMTP option and only uses PHP mail then we have done this.

Yes my Snr technician has seemingly dealt with it.

Thanks

SMB


Tony

  • Support Staff

September 8, 2020 at 1:40 pm

Great, then I’m glad your Snr technician found a solution.

Any further problems just let us know.


SteveMBragg

September 8, 2020 at 3:08 pm

Thanks Tony…..

Steve

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  SteveMBragg 2 weeks, 4 days ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!