Support

Home Forums Event Espresso Premium Not Able to Link Logo to PDF Invoice

Not Able to Link Logo to PDF Invoice

Posted: January 24, 2014 at 12:24 pm


Sidney Harrell

January 24, 2014 at 1:23 pm

Is it a jpeg or gif file? If you change it from a URL to a directory location does it work? Your server may have the allow_url_fopen disabled, or you may be missing the GD image manipulation library.


Ronald Aoki

January 24, 2014 at 2:36 pm

Hi, Sidney. It is a jpeg file. Here is the URL that I pasted into the URL field in the invoice payment gateway.

http://dev.hdihawaii.com/wp-content/uploads/2014/01/image001.jpg

Not sure how to do that (change from URL to directory location).

Do I need to check with my host to have that enabled, if so?

Where can I find the GD image manipulation library? Is this something that is downloaded from EE or from WP?

Please advise. I’d really like to have the logo on the invoices.

Thanks.


Dean

January 27, 2014 at 1:24 am

Hi Ronald,

To clarify, you have added the URL to the Logo URL field in the Invoice settings?

Can you make sure that there are no spaces at the start and end of the URL please?


Ronald Aoki

January 27, 2014 at 1:51 am

Hello Dean,

Yes, that is correct, added to the Invoice Payment Setting. Checked it again and there are no spaces at the start or the end of the URL.

Please advise.


Dean

January 27, 2014 at 4:47 am

OK, was worth checking the simple things!

Next check, please go to http://dev.hdihawaii.com/wp-admin/options.php and search for image_default_link_type and make sure the field next to it contains the word file. If it doesn’t add it and save and see if that helps.

Can you also go to Event Espresso > System Status and click the generate report button at the top, then copy and paste the details here please?


Ronald Aoki

January 27, 2014 at 7:27 pm

Hello Dean:

Yes, image_default_link_type had the word “file” in the field next to it.

Hope the report below helps:

<code>
=============================================================================================
 Versions
=============================================================================================
Event Espresso version: 	3.1.36.1.P
WordPress version: 	WP 3.8.1
Installed plugins: 	Easy Testimonials by Illuminati Karate version 1.5.9, Event Espresso - Calendar by Event Espresso version 2.2.0.p, Event Espresso - Custom Template Display by Event Espresso version 1.0, Event Espresso - MailChimp Integration by  version 1.2, Event Espresso - Social Media by Event Espresso version 1.1.7.p, Event Espresso Requirements Check by Event Espresso version 0.9, Event Espresso by Event Espresso version 3.1.36.1.P, Jetpack by WordPress.com by Automattic version 2.7, My Custom CSS by Salvatore Noschese - DarkWolf version 1.5, Social Media Icons Widget by Akin Williams version 1.2.7, WP Clone by WP Academy by WP Academy version 2.1.6

=============================================================================================
 Settings
=============================================================================================
Home URL: 	http://dev.hdihawaii.com
Site URL: 	http://dev.hdihawaii.com

=============================================================================================
 Registration Pages
=============================================================================================
Event Page: 	#5 - http://dev.hdihawaii.com/registration/
Payment/Thank You Page: 	#6 - http://dev.hdihawaii.com/thank-you/
Transaction Notification Page: 	#8 - http://dev.hdihawaii.com/transactions/
Cancel Return Page: 	#7 - http://dev.hdihawaii.com/registration-cancelled/

=============================================================================================
 Server Environment
=============================================================================================
PHP Version: 	5.3.13
Server Software: 	Apache/2
WP Max Upload Size: 	20 MB
Server upload_max_filesize: 	20 MB
Server post_max_size: 	20 MB
WP Memory Limit: 	40 MB - We recommend setting memory to at least 64MB. See: Increasing memory allocated to PHP
WP Debug Mode: 	No
Espresso Logging: 	Log directory is writable.

=============================================================================================
 PHP Sessions
=============================================================================================
Session save path: 	/home/users/web/b1781/ipw.hdihawaii/public_html/cgi-bin/tmp is writable.
Session name: 	PHPSESSID

=============================================================================================
 Remote Posting/IPN
=============================================================================================
fsockopen/cURL: 	
                    	
	                    	Your server has fsockopen and cURL enabled.                    	
                    
</code>


Sidney Harrell

January 27, 2014 at 8:58 pm

The GD library is a php library that allows php to manipulate image files. Your host more than likely has it installed already.
Can you download this plugin, install and activate it, then go to Tools->Event Espresso Requirements Check and tell us what it says next to ‘PHP equipped with GD image manipulation library’ and ‘PHP allowed to open files over url protocol’? (Those aren’t in the regular version, I just added them in)


Ronald Aoki

January 29, 2014 at 9:17 pm

Hello, When I click on the link to check my PHP Info, I get taken to a 404 Not Found page. Please advise.


Dean

January 30, 2014 at 6:05 am

Hi,

I tested the download above and the plugin worked fine here, it should look like this http://take.ms/SxIv0


Ronald Aoki

January 30, 2014 at 5:25 pm

Hi.

The plugin works fine and I can see that screen, but it doesn’t show the GD Image Manip. setting. I have to click on a link to see more details, and when I do, I get taken to a 404 page.

http://www.screencast.com/t/CEkW1U74BJ

Something must be wrong on my server/with my hosting. Please advise.


Dean

January 31, 2014 at 4:29 am

Hi Ronald,

The server config is set up in a way that the Requirements plugin cant detect everything. It may be a good idea to have a quick word with your host to see if the GD library is installed or not.


Ronald Aoki

February 3, 2014 at 5:17 pm

Hey, Dean:

This is the response I got back from my host:

“PHP supports image manipulation library and I have enabled fopen in the php.ini file so that you can open files in php.”

But when I try to link a logo to PDF invoice in EE, I still get the same error message.

Any ideas? Thank you.


Dean

February 4, 2014 at 2:07 am

Is it possible to get your login details in order to look into this?

If so, please send them via http://eventespresso.com/send-login-details/

NOTE: login details need to be Admin level and FTP details are appreciated.

Also can you advise which file in the Media Library you are trying to use for the logo?


Ronald Aoki

February 4, 2014 at 8:22 pm

Dean,

Please advise if you received my PHP report URL.

Thank you.


Dean

February 5, 2014 at 12:18 am

Hi,

Yes we got that info, but I wanted to test out the actual media file on your site to see if there is a different reason why it is not working.

The login details do not seem to work, can you clarify these please? (via email)

Also please remove the phpinfo() file from your site when not in active use, it’s a security risk to leave it available.


Ronald Aoki

February 5, 2014 at 3:23 am

Will do. Thank you.


Dean

February 6, 2014 at 12:53 am

Hi,

Thanks again for the login details.

Everything is still pointing towards a server issue. The last message from your host said “I have enabled fopen in the php.ini”

Is it possible to confirm that in the php.ini it definitely has allow_url_fopen = on ?

The error is suggesting that this is not “on” but the message from your host suggests it is.


Ronald Aoki

February 6, 2014 at 1:46 am

Dean,

I just checked the PHP info again and it is set to OFF. It was not enabled after all. Sent them a request to enable it, so hopefully it should be ready to test again from your side by tomorrow.

Thank you for all of your hard work and for helping me. I really appreciate it.


Dean

February 6, 2014 at 1:55 am

No problem. You can test it easily once you get the OK from the host, just add an image in the Invoice settings and try to download an invoice. If it throws an error let me know.


Ronald Aoki

February 6, 2014 at 7:19 pm

It works! Thank you, Dean, for all of your help! Case closed.

The support post ‘Not Able to Link Logo to PDF Invoice’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Ronald Aoki 5 years, 10 months ago ago

Topic Tags

Tagged: , , ,

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!