Support

Home Forums Community Forum No Emails are sent to event registrant

No Emails are sent to event registrant

Posted: March 6, 2017 at 9:11 am


bsukalp

March 6, 2017 at 9:11 am

I have setup Event Espresso 4.9.
The test payment works as expected. However, no emails are sent to event registrant.
I have red several forums where they talk about
1. Changing [CO_FORMATTED_EMAIL] to [CO_EMAIL].
2. ensuring that emails have been recorded correctly.
3. Testing if the email is sent using the admin portal Event Espresso plugin inside the wordpress.

All of the above three are success.

We have using WP email SMTP to handle emails.

Event Espresso website talks about installing transactional email services.
Could this be a problem?
Are there any other free options we can use which is easy to install and use?

Thank You!

  • This topic was modified 4 years, 7 months ago by  Tony. Reason: Not a calendar question


Tony

  • Support Staff

March 6, 2017 at 10:02 am

It may be an issue with your hosts mail server yes.

If you look within the message activity table (Event Espresso -> Messages -> Message activity) what colour status bar do the message shown there have? (the bar on the left of each message)

Most of the transactional email services we list have a free tier available and are fairly easy to set up:

https://eventespresso.com/wiki/postmark-app-mandrill-transactional-email-handling-services/


bsukalp

March 6, 2017 at 10:08 am

Hi Tony,

Thanks for your reply.
Answer to your question: The status bar is red in color.

We have only gmail email address.
SendinBlue rejected our request because apparently our IP has bad reputation in sending Spam. We share a VPS.

Is it not possible to setup a transactional email using gmail? Because we do not YET have our own domain specific email address. 🙁

If nothing works but the services referred on the link you provided, do you advice us on using any specific service?


Lorenzo Orlando Caum

  • Support Staff

March 6, 2017 at 10:45 am

Hello,

A status of failed means that there is a problem that is preventing those emails from going out.

If you are using a gmail account and are using a SMTP service, then you may already be sending from a gmail account.

Does the email address that is set for the SMTP plugin also match the email that is set through Event Espresso –> General Settings –> Primary Contact Email?


Lorenzo


bsukalp

March 6, 2017 at 12:19 pm

Hi Lorenzo,
Yes both ‘Event Espresso –> General Settings –> Primary Contact Email’ and ’email set up under WP email SMTP’ is the same.

I also tried sending test email from plugin ‘WP Email SMTP’ and test email from
‘Event Espresso plugin’. It works with no problem.

It is only when user register, pays for the event no emails are sent. I have also configured email for every user action such as registration and payment success etc.

Any idea what must be going wring or something I can check or configure?


bsukalp

March 6, 2017 at 1:56 pm

Just answering my own question,

Apparently the problem was about ‘Not using Transactional email Service’. I just configured the transactional email with Post mark and everything worked just fine.

Thanks all for keeping me excited about this project of mine. 😉


Tony

  • Support Staff

March 7, 2017 at 3:09 am

You’re most welcome, I’m glad its working for you.

The support post ‘No Emails are sent to event registrant’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso