Home Forums Event Espresso Premium Multiple Events Registration – Empty Cart Error

Multiple Events Registration – Empty Cart Error

Posted: January 9, 2013 at 4:14 am

Ross Willits

January 9, 2013 at 4:14 am

I’m experiencing an issue with a client’s site that I just cannot figure out. I have created a couple of test events that use the following shortcode:

[ESPRESSO_CART_LINK anchor=”Register Today!” direct_to_cart=1 moving_to_cart=”Redirecting to cart…”]

See one here:

When pressing the Register button, the page goes to the cart, but displays the following error:

“It looks like you are attempting to refresh a page after completing your registration or your cart is empty. Please go to the events page and try again.”

What’s most frustrating is that this used to work just fine, but now doesn’t.

I was in development with things working, and was about to start customizing things with templates in wp-content/uploads/espresso/templates, but found I did not have sufficient permissions to upload.

I contacted the host, and had them enable read/write/execute for all accounts on the following folders:


I then proceeded to upload what I thought was the full set of unadulterated current templates to uploads/espresso/templates. When I hit the event and pressed the register button, I got the error for the first time.

So, I removed all of the templates I’d uploaded so that uploads/espresso/templates was empty again.

Still got the error.

I have scoured the web and your forums for solutions, and found a series of things to try, including:

  • Disabling other plugins
  • Switching themes
  • Disabling and reenabling all Espresso plugins
  • Making sure it wasn’t old templates that were uploaded (but everything has been removed from uploads/espresso/templates anyway)

I am at a loss. I found references to session issues related to permissions on the /tmp folder, but this was all working fine before, and the host says that nothing was changed in that regard.

I’m stuck. Please help!


January 9, 2013 at 4:32 am

Hi Ross,

OK, firstly, thanks for running through some checks already. My thoughts here is that it seems to be a possible issue with the templates but you have clearly said these have since been removed.

Do you know what the host actually did permissions wise? Have you checked the folder permissions yourself (not just for upload but a sweep of Event Espresso checking folder/file permissions)?

It just seems that this occurred after the permissions were changed.

Ross Willits

January 9, 2013 at 4:58 am

Hey Dean,

Thanks for the quick reply!

I checked permissions and inside uploads/espresso, all folders are owned by the user steppingstoneth and permissions are as follows:

gateways: rwx r-x r-x (755)
logs: rwx r-x r-x (755)
templates: rwx r-x r-x (755)

The parent folder espresso is also rwx r-x r-x (755)

They had changed the owner for from Apache to steppingstoneth and specified a group of psacln (?) so that we could upload to the folders.

Would anything above be an issue? Are there other key folders I should be checking permissions on?

I just tried changing the permissions on all the folders mentioned above to rwx rwx rwx but that doesn’t seem to “stick” (always reverts back to rwx r-x r-x). If they should all be 777 I am going to have to contact the host again.

Please advise!

Ross Willits

January 9, 2013 at 5:01 am

FYI, I checked all the espresso related folders in the plugins folder as well, and they’re all rwx r-x r-x (755) as well.


January 9, 2013 at 5:11 am

Hi Ross,

No they should not be 777, its too open, 755 for directories and 644 for files should be fine.

I have done some reading up on past forums and it is more and more confirming my thoughts that this is an issue with the host, most likely the session or cache settings.

Have you tried running the Event Espresso Requirements plugin? It gives some basic info about possible server problems.

Who is your host? Do you know if they have server side caching? That could also affect the shopping cart.

Ross Willits

January 9, 2013 at 5:34 am

The plugin returned the following:

Passed with warnings.
Your server supports the minimum requirements but may experience some difficulties with all features. See the Event Espresso Requirements page for more information. Get your copy of Event Espresso here.

The host is I am not sure if they have server side caching or not. Can you give me some specific things to enquire of them? Like, what the session settings should be or what cache settings should be?

The most frustrating thing is that it was working before, it just needed some template work to match our theme.


  • Support Staff

January 9, 2013 at 8:53 am

Hi Ross,

Ask them to check your error logs. When Event Espresso tries to write to a session, something isn’t working.

You can also try adding something like this to your footer to track the session data:

                    if ( is_user_logged_in() ) {
                        print_r ($_SESSION); 

As a reference, the phpinfo section on sessions should look something like this screenshot.

Ross Willits

January 10, 2013 at 4:41 am

Hey Josh,

I looked at the error logs and confirmed that it is a permissions error on the tmp folder for sessions, which unfortunately is outside of my control. See lines from the log below.

[Wed Jan 09 06:26:52 2013] [warn] [client] mod_fcgid: stderr: PHP Warning: session_start(): open(/var/lib/php/session/sess_9h3vrldagi1paegp2m5qdjver3, O_RDWR) failed: Permission denied (13) in /var/www/vhosts/ on line 72
[Wed Jan 09 06:26:52 2013] [warn] [client] mod_fcgid: stderr: PHP Warning: Unknown: open(/var/lib/php/session/sess_9h3vrldagi1paegp2m5qdjver3, O_RDWR) failed: Permission denied (13) in Unknown on line 0
[Wed Jan 09 06:26:52 2013] [warn] [client] mod_fcgid: stderr: PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php/session) in Unknown on line 0

I’m going to have to contact their support again, what permissions should that folder have in order for Event Espresso to have access to it?

Please advise and I’ll get hold of VISI support with that information.




  • Support Staff

January 10, 2013 at 11:16 am

They will need to set the permissions to allow PHP to write to tmp, or they can set the session save path to another folder that PHP can already write to.

The support post ‘Multiple Events Registration – Empty Cart Error’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Event Espresso