Support

Home Forums Event Espresso Premium Multi Event Registration – Not saving data

Multi Event Registration – Not saving data

Posted: September 21, 2012 at 1:01 pm


Tyler Brown

September 21, 2012 at 1:01 pm

I am doing a sports registration portal.

Parents register their children.

Parents have multiple children so they may be adding one child to one age group and another child to another.

For simplicities sake:

There are 3 custom questions.

Child’s Name DOB Sex

The problem.

Parent Joe registers his two kids: Johnny U10 category Sally U16 category

What I see.

Joe comes through as the attendee for both, and Johnny’s data is visible in exported excel spreadsheet.

Sally’s data is gone. All of the custom fields in the spreadsheet for the U16 are blank. I haven’t checked the DB yet, but this is a deal breaker for me.

  • This topic was modified 8 years, 6 months ago by  Seth Shoultes.


Seth Shoultes

  • Support Staff

September 21, 2012 at 1:19 pm

Sounds like something is wrong with the install. What version of WordPress and Event Espresso are you using? What plugins do you have installed? What is the theme you are using?


Tyler Brown

September 21, 2012 at 1:21 pm

WordPress 3.4.2 EE 3.1.26 but I have made some modifications for use with qTranslate. Mainly display.

I can try a fresh install, but basically at this point I think I am going to have kibosh the entire thing because it was a few days of work to get the multi-lang working. Is there any way to view the custom questions without exporting as excel? I need to see what is in the DB.


Tyler Brown

September 21, 2012 at 1:37 pm

I just checked the db… and there is nothing being saved of the custom questions. Looks like my board of directors is pulling the plug on this solution. How do I go about requesting a refund for purchase?


Tyler Brown

September 21, 2012 at 1:49 pm

I just tested a completely clean install… No modifications, latest wordpress, latest EE. No qtrans.

Same issue.

Steps to reproduce:
1) Create a new question: “Custom Question 1” make it required
2) Create a new question group: “Question group 1”
3) Add “Custom Question 1” to “Question group 1”
4) Create two events “Event A” and “Event B”
5) Add “Custom group 1” to questions for both events.
6) Add both events to Cart.
7) Click View Cart
8) Click Complete Registration
9) Fill in all information. Provide different answers for both of the custom question instances.
10) Complete registration (note no errors)
11) Download excel reports for both
12) Note for event B response to custom question is blank.


Seth Shoultes

  • Support Staff

September 21, 2012 at 2:00 pm

Rather than scrapping the system, we would like see this working for you. Can you send us access to one of the sites?

Please send WordPress admin level log in credentials via the contact form on this page: https://eventespresso.com/contact/

Select the “I am sending login info as requested” department form.


Tyler Brown

September 21, 2012 at 2:05 pm

Alright done. I sent info to both sites, the updated and the live site. I will be available to work with you as needed.


Seth Shoultes

  • Support Staff

September 21, 2012 at 2:12 pm

Got your info. I am trying to reproduce the problem on my server first.


Tyler Brown

September 21, 2012 at 2:44 pm

Alright keep me updated as to how it goes. I am open to all solutions at this point, kludgy or otherwise.


Seth Shoultes

  • Support Staff

September 21, 2012 at 3:01 pm

I was able to reproduce this. Myself and another developer are looking it it. Not sure why this hasn’t come up before. Very strange.


Seth Shoultes

  • Support Staff

September 21, 2012 at 3:49 pm

Tyler,

I just re-saved Event B on your test site and things started working.


Tyler Brown

September 21, 2012 at 3:50 pm

Spontaneously?


Tyler Brown

September 21, 2012 at 3:59 pm

I’m having no such love on the production site…


Seth Shoultes

  • Support Staff

September 21, 2012 at 4:31 pm

Did you try resaving the events on the production site?


Seth Shoultes

  • Support Staff

September 21, 2012 at 4:34 pm

I uploaded the latest development version to your test site. Do you want to try that in the production site? You don’t have to overwrite the files, just upload it and activate it. After deactivating the other version of course.


Brent Christensen

  • Support Staff

September 21, 2012 at 5:17 pm

Hi Tyler,

In the event editor in the Event Espresso admin, there are two boxes in the sidebar on the bottom right. One is labelled “Event Questions for Primary Attendee” and the other is labelled “Event Questions for Additional Attendees”.

Each of these boxes lists all of the available Question Groups that can be added to an event’s registration form. If you check off the box for a question group, then those questions will be asked AND saved for that event. You only had the question groups checked off for the primary attendee (the person that performs the payment when registering). This is why questions for additional attendees were not being saved.

If you want the system to save answers for the additional attendees in the cart, you need to add the same question groups by checking off the appropriate question groups in the “Event Questions for Additional Attendees” box.

I have taken the liberty to do this for you. I’ve only added the same question groups as were added in the “Event Questions for Primary Attendee” box.

However, just for contrast, I have left the “Event Questions for Additional Attendee” questions for the U16 event UN-checked. If you perform test registrations using ANY two events OTHER than the U16 event, then download the csv file for the events, you will see ALL of the custom questions. BUT… if you do the same test, but use the U16 event as the second event, the corresponding csv file will be missing the custom questions.

You will need to check off the appropriate question groups for the additional attendees for the U16 event before it will work the way you want it to.

Let us know if you have any further questions regarding this, or any additional issues that we can help you with.

Brent

The support post ‘Multi Event Registration – Not saving data’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Brent Christensen 8 years, 6 months ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!