Support

Home Forums Event Espresso Premium Move website to other domain gives Payment troubles

Move website to other domain gives Payment troubles

Posted: August 2, 2012 at 7:18 am


rgroot

August 2, 2012 at 7:18 am

Dear,

I developed a website on a DEVELOPMENT environment (development.domain.com), there everything (including events, payments, etc) is working perfect.

Now the website is done, i have to move this website to the production environment (www.domain.com). When i do this the whole site is working except the payment layer in espresso, i can register myself for an event (fill in my information as usable), click on register and i receive a message that i’ve been succesfully registerd to the event and that i received a confirmation e-mail, this is true. But the payment page (where you can select a payment provider (PayPal, iDeal, CreditCard, etc) isn’t showing!!

When i have al look in the backend under participants the payment status is “pending”.

I move a lot of wordpress websites between hosts and domains so i know how to do this (change some database records, chance wp-config.php, etc), this always works for me. But in this site only the espresso plugin isn’t working properly.

When i move the site back to the development environment, change everything back the payment layer is working again..

Any ideas how to solve this problem?

Thanks already.

Kevin (Netherlands).


Josh

  • Support Staff

August 2, 2012 at 7:26 am

Have you tried re-saving the payment option settings now that it’s on the new server?


rgroot

August 2, 2012 at 7:32 am

Hi Josh,

I did now but didn’t changed anything.


Josh

  • Support Staff

August 2, 2012 at 8:27 am

can you do a search in the database (should be in the options table) for the old server path? Normally, when the payment options get saved, the paths should get updated.


rgroot

August 2, 2012 at 8:54 am

Hi Josh,

I replaced everything in the database tables that has to do with paths, urls, etc. This isn’t the problem.

I even used a search & replace script to replace a lot;
http://interconnectit.com/124/search-and-replace-for-wordpress-databases/


Josh

  • Support Staff

August 2, 2012 at 9:13 am

If you’re certain this isn’t a database issue, then you might try uploading a fresh copy of Event Espresso. Also check /wp-content/uploads/espresso/gateways and make sure no gateway folders are in this directory.


dancrum

August 2, 2012 at 9:28 am

I’m having a similar issue with moving between servers.

After I have migrated the site, everything works as planned up until confirming the payment and accessing the gateway. A quick peek into the Payment Settings page shows the following error for every gateway:

Warning: array_key_exists() [function.array-key-exists]: The second argument should be either an array or an object in /nas01/HostingVol1/19/47619/domain.com/public/wp-content/plugins/event-espresso.3.1.21.P/gateways/check/settings.php on line 37

The file path looks to be correct, so not sure why this is happening.


Josh

  • Support Staff

August 2, 2012 at 9:34 am

Try updating to the latest version of Event Espresso. Here are detailed upgrade instructions: http://eventespresso.com/wiki/updating-event-espresso/


dancrum

August 2, 2012 at 9:59 am

The issue persists after the upgrade.

Furthermore, on the payment confirmation page (client-side), I am also getting this error, preventing me from accessing gateway:

Warning: Invalid argument supplied for foreach() in /nas01/HostingVol1/19/47619/domain.com/public/wp-content/uploads/espresso/gateways/gateway_display.php on line 57


Josh

  • Support Staff

August 2, 2012 at 10:01 am

Remove the files from /wp-content/uploads/espresso/gateways and re-save the gateway settings.


dancrum

August 2, 2012 at 10:14 am

Still unable to access the gateway settings.

enter image description here


Josh

  • Support Staff

August 2, 2012 at 10:21 am

Please see this post:

http://eventespresso.com/topic/errors-on-manage-payment-gateways-page/


dancrum

August 2, 2012 at 10:36 am

I actually solved the issue, for me at least.

In the gateway’s settings.php file, I just changed any instance of array_key_exists() to property_exists(), and that cleared it right up. Seems array_key_exists isn’t supported for objects in newer PHP installations.

Cheers!


Josh

  • Support Staff

August 2, 2012 at 10:44 am

Thanks for sharing your solution. Which version of PHP?


rgroot

August 3, 2012 at 1:51 am

Hi All,

This morning i tried al lot (everything what you did above) but no luck for me.

I don’t have the error messages that dancrum had, i enabled wp_debug mode and checked the PHP error_reporting (E_ALL) so it should print them. For your information, i use PHP 5.3.15 (CGI mode).

I tried to disable all payment options and re-enable them again, no luck.

I tried to update the event espresso to latest version (i used .24 before, now on latest release), no luck

At the end i tried to completely uninstall the event espresso module, remove all files in uploads directory. Next i re-installed the latest version but still no payment selection page!!!!! even with the default templates that comes with espresso.

On thing i found strange, was that all settings i had before removing the module where still there after the re-installation?? is there a way to remove these also? so that i am 100% clean?

P.S. i never changed the licensed domain on eventsespresso.com, this is still standing to development.domain.com. Could it be that this could be the problem?

Thanks.


rgroot

August 3, 2012 at 1:59 am

Small update:

I disabled all other plugins that where installed, only espresso enabled and now i am getting the following error message on the confirmation page;

Warning: require_once(/home/therese/domains/theresegodthelp.nl/public_html/wp-content/plugins/event-espresso/gateways/html_invoice/init.php) [function.require-once]: failed to open stream: No such file or directory in /home/therese/domains/theresegodthelp.nl/public_html/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058

Fatal error: require_once() [function.require]: Failed opening required '/home/therese/domains/theresegodthelp.nl/public_html/wp-content/plugins/event-espresso/gateways/html_invoice/init.php' (include_path='.:/usr/local/lib/php') in /home/therese/domains/theresegodthelp.nl/public_html/wp-content/plugins/event-espresso/includes/functions/main.php on line 1058

I checked the location and indeed the directory html_invoice doesn’t exists. Only the folder invoice

I checked the events-espresso.zip file that’s downloaded on your website (.25 version) and even there the directory html_invoice doesn’t exists. Only the folder invoice

  • This reply was modified 7 years, 2 months ago by  rgroot.
  • This reply was modified 7 years, 2 months ago by  rgroot.


rgroot

August 3, 2012 at 2:34 am

I created a new domain with a clean install of wordpress and a clean install of espresso and it works immediately (same server, same configuration).

http://wordpress.ucreation.nl/event-registration/

  • This reply was modified 7 years, 2 months ago by  rgroot.


rgroot

August 3, 2012 at 3:37 am

Found an other problem;

I think the /transactions/ page isn’t rendered right (short code isn’t executed).

When i go tho this page, i see the text [ESPRESSO_TXN_PAGE]. When i go this page on my test environment i get the message “ID not supplied.” what says that the shortcode is working well.

I checked the page in the backend, and there is no bloat html around it what could give us some strange stuff.


Josh

  • Support Staff

August 3, 2012 at 7:57 am

The license key wouldn’t affect the functionality of the plugin, only the update/notification feature.

The transactions page is rendering as it should. If you visit that page and it is set up correctly, it should say ID not supplied.

I think you need to clear out the active gateways value in the database. Use phpmyadmin, or use the adminer plugin to go into the wp_options table. Do a search for event_espresso_active_gateways in the option name column:

enter image description here

Then edit the option_value so it’s: a:0:{}

enter image description here


rgroot

August 3, 2012 at 8:37 am

Josh,

Damm you’re a life-saver!! I replaced the value and it works!!!

Thanks


Sidney Harrell

October 16, 2012 at 4:25 pm

Hi dancrum,
The $active_gateways should be an array and not an object. Can you check in the wp_options table for the ‘event_espresso_active_gateways’ option?

The support post ‘Move website to other domain gives Payment troubles’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Sidney Harrell 7 years ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!