Support

Home Forums Event Espresso Premium Mollie / WordPress update gone wrong

Mollie / WordPress update gone wrong

Posted: May 3, 2020 at 6:32 am


sara.bosman

May 3, 2020 at 6:32 am

Ok, this is weird. Following an update from WordPress 5.4.0 to 5.4.1, all of our registrants who had registered in the past using Mollie, were sent a ‘Registration Approved’ mail again, even for events that finished weeks ago, at the same time at May 1st, 15h55. An Activity Log screenshot of the moment:
screenshot
Any idea why? No-one was logged in around that time.


sara.bosman

May 3, 2020 at 6:33 am

(it was an automatic update btw)


Tony

  • Support Staff

May 4, 2020 at 6:55 am

Hi there,

Are you 100% certain that users received the email back when they registered?

The reason I ask is the only time we’ve seen an issue like this was due to an issue with WP_CRON causing the emails to sit with a status of ‘waiting to send’, an update then caused EE to recheck all its settings (including cron jobs) which then found the issue and automatically fixed it but that then caused the backlog of emails to send. We were never able to reproduce the issue itself when the user reported this but found it within a database backup of the site in question.

Also, are you using a transactional email service at all on the site?


sara.bosman

May 4, 2020 at 8:20 am

Yes, they received it twice: one during registration, and once May 1st, 15h55. I can see it through the related messages, and in my email logger, and it is confirmed by customers.
As for the email configuration: I just mailed you a system info file (generated by Email log WP plugin)


Tony

  • Support Staff

May 4, 2020 at 8:57 am

If you go to Event Espresso -> Messages -> Settings.

You’ll find the setting ‘Generate and send all messages’, what is that set to?


sara.bosman

May 4, 2020 at 1:25 pm

“On the same request”


Tony

  • Support Staff

May 5, 2020 at 3:21 am

Hmm ok, that means you aren’t using the message queue system at all then.

Do you have a database backup of the site before the update ran and would you be willing to send me it?

What I would like to do is install a copy of the site locally with email disabled and then run the update to see if the messages retrigger again, if I can reproduce then I can then work through to find out what is causing the problem.


Tony

  • Support Staff

May 5, 2020 at 7:48 am

Also, is it only the registration approved messages that sent or all messages?

Is ‘my’ pending payment message still in available in the message queue or was that removed with the registration I made?

I didn’t receive a duplicate email for pending payment email so just trying to figure out why as that may help narrow down the cause.

You must be logged in to reply to this support post. Sign In or Register for an Account

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: publish

Updated by  Tony 3 weeks ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!