Support

Home Forums Event Espresso Premium Mobile App API Error

Mobile App API Error

Posted: March 2, 2019 at 10:34 am


fastprep

March 2, 2019 at 10:34 am

Hi there

I was informed by a colleague that she was getting an error when using the EE mobile app…

Error message reads as follows: “You cannot have WP API v1 and v2 active simultaneously. Please deactivate WP API v1 plugin…”

Please can you advise on how to resolve this? Im not sure what ‘API Plugin’ is being referred to here. We are using EE4.

Kind Regards


Tony

  • Support Staff

March 4, 2019 at 6:49 am

Hi there,

It’s the REST API plugin.

If you go to Dashboard -> Plugins, can you see a REST API plugin enabled there?

If so disable that and check if the error is removed.


fastprep

March 4, 2019 at 7:12 am

I am unable to find the above-mentioned plugin…

could it be something else causing the problem?


Tony

  • Support Staff

March 4, 2019 at 9:26 am

In that case, we’ll need a list of plugins active on the site as you should only get the above if the old REST API is active.


fastprep

March 6, 2019 at 2:22 am

Hi Tony

Please see the link to view our plugins list:

**REMOVED**

Let me know what you think might be causing the problem

  • This reply was modified 4 months, 1 week ago by  Tony.


Tony

  • Support Staff

March 6, 2019 at 2:35 pm

Hmm, nothing there is sticking out.

Can you send me login details I can use in the app to so I can test logging in and view the request?

If so please use this form: https://eventespresso.com/send-login-details/


Tony

  • Support Staff

March 6, 2019 at 2:53 pm

Also, have you tested the app at various times and still get the same error?

The reason I ask when you reported this, I checked your WP REST API endpoint to confirm it worked (the app uses it) and it wouldn’t load, at least not on most of the requests I sent.

Then a little later I repeated the tests and it worked fine, so its possible your getting that error when the server is unable to process the request.


Tony

  • Support Staff

March 7, 2019 at 3:20 pm

Hi there,

Thanks for the login details but you didn’t answer my above question?

Logging into the site with the Android app I don’t have any issues at all, which version of app are you running?


fastprep

March 7, 2019 at 3:46 pm

Hi Tony

Sorry, I missed that… let me check with my colleague.
I will also recommend re-installation of the app and see if resolved.

Thanks

The support post ‘Mobile App API Error’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  fastprep 4 months, 1 week ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!