Support

Home Forums Event Espresso Premium Missing bookings from admin -2

Missing bookings from admin -2

Posted: January 24, 2020 at 8:04 am


Ion Paciu

January 24, 2020 at 8:04 am

Hi,

I’m recalling this issue here:
https://eventespresso.com/topic/missing-bookings-from-admin/

I removed Speed Booster as well spoke with WP Engine to cache out those links.
I did not turn off Autoptimize as it’s really important for site speed (we tested too many until now, this is worked ok so far).

The problem is booking gets past the registration page, the admin and full user email confirmation is generated – which means the data gets parsed by EE and it’s not a cache issue. The booking does not show up in admin interface.

I have turned on full EE logging and the user details appears in the log as well.
We have a testing enviroment with website copied in full on wpengine, is there anything you can help us with?
I believe it’s some sort of bug, it’s very difficult to test as it appears once in a while.

Thanks


Josh

  • Support Staff

January 24, 2020 at 10:08 am

Hi,

I still recommend deactivating Autoptimize because this same issue was reported before and it turned out to be caused by Autoptimize. The fact that they’re getting past the registration page may not relevant because the breakage could be happening on the following request. Especially if the end user is hitting the back button during the registration process because there was an error caused by Autoptimize.

In any case if you’re not going to turn off Autoptimize you can at least change its settings to exclude Event Espresso’s scripts from Autoptimize. That’s actually something the developer of Autoptimize has recommended to someone else that reported trouble with forms on their site. This is no guarantee it will fix the issue though, because other scripts on the page may be broken. You go to Autoptimize settings, then add
plugins/event-espresso/
to the comma-separated values in the “Exclude scripts from Autoptimize” field, then click Save Changes and Empty Cache.

Also, you can check with WPEngine to see if they recommend running “Cache Enabler by KeyCDN”, that plugin may be conflicting with WPEngine’s built in cache.


Ion Paciu

January 24, 2020 at 12:37 pm

I’ll try any of the above and see if it gets back.
Thanks

The support post ‘Missing bookings from admin -2’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Ion Paciu 8 months ago ago

Topic Tags

Notifications

This topic is:
pending
Do NOT follow this link or you will be banned from the site!