Home Forums Event Espresso Premium Messages not sending to approved registrants

Messages not sending to approved registrants

Posted: January 22, 2020 at 2:28 pm


January 22, 2020 at 2:28 pm

EE has stopped sending auto messages to approved registrants. In the message activity log, the “To” field is “No recipient” on all outgoing messages. Everything appears to be correct w/ message settings. After speaking with the person who coordinates our site hosting, I think this might be a server issue. Here was his message to me:

“I found this error (BELOW) repeating in the server logs. Can you share it with EE and see what they say? We might need to tweak the server settings, but I am hoping they can tell you what they need the settings to be to resolve this issue. I am also creating a ticket with our server admin team to see what they can do.
[16-Jan-2020 18:37:16 UTC] PHP Warning: getimagesize(): http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /home/thriveweb/public_html/wp-content/plugins/event-espresso-core-reg/core/libraries/shortcodes/EE_Transaction_Shortcodes.lib.php on line 499”

I also received this update from him: “Server admin update: the PHP settings for the “allow_url_fopen” directive is now enabled.”

Are there any other settings we should change? Anything else we should try to correct this b/c even after the changes he made, the messages are still not sending? Thank you.


  • Support Staff

January 22, 2020 at 4:58 pm


You could go to your site’s Tools > Site Health page and check to see if the Scheduled tasks (also known as wp_cron events) are working. Usually if they’re not working the Site Health page will have some information about that.


January 22, 2020 at 6:01 pm

It says scheduled events are running.


  • Support Staff

January 23, 2020 at 12:02 pm

It may help to go to Event Espresso > Messages > Message Settings and set the option for emails to be sent on the same request.

If at that point going forward new registrations result in emails sending then that’s an indication scheduled events (or wp_cron) isn’t working as expected on your server.

The support post ‘Messages not sending to approved registrants’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Josh 2 months, 2 weeks ago ago

Topic Tags



This topic is: not resolved
Do NOT follow this link or you will be banned from the site!