Support

Home Forums Event Espresso Premium Messages are not sent reliably

Messages are not sent reliably

Posted: October 16, 2019 at 3:19 am


TownCountry

October 16, 2019 at 3:19 am

Messages (registration confirmation) are not sent reliably. We have registrations, but the confirmation email is missing.


Tony

  • Support Staff

October 16, 2019 at 4:07 am

Hi there,

Which payment method are you using?

Messages have multiple contexts, for example the Registration Approved messages (which I assume if what you mean by registration confirmation) has an ‘Event Admin’ and ‘Registrant’ content enabled by default. Meaning when it’s triggered it sends an email to the registrant and the event admin, which of thos is missing, or is it both?

If you find a registration this has happened on in Event Espresso -> Registrations.

Click on the icon in the actions section for that registration. EE will now display all of the messages triggered for that registration, can you see the messages there?


TownCountry

October 16, 2019 at 5:04 am

The payment method is bank draft. The message type is “Registration Approved”. Neihter the messade to the ‘Event Admin’ nor to the ‘Primary Registrant’ is send. At Event Espresso -> Registrations -> View Related Messages is also no message to see.


Tony

  • Support Staff

October 16, 2019 at 5:27 am

The payment method is bank draft.

Ok, so messages would only be triggered if they selected back draft and then finalized the registration, did the user finalize the registration?

You can check by navigating to Event Espresso -> Registrations, find the same registration from above and this time click on the TXN date field.

That will take you to the user transaction in EE.

Click on ‘view additional transaction session details’

What steps show completed in ‘Registration Step Progress’?

Neihter the messade to the ‘Event Admin’ nor to the ‘Primary Registrant’ is send

The primary registrant context is not enabled by default so unless you have enabled that context it is expected that it wouldn’t send (The ‘Event Admin’ and ‘Registrant’ contexts are enabled for that message type and should show, but not Primary Registrant).

At Event Espresso -> Registrations -> View Related Messages is also no message to see.

Ok, in that case, sounds like the messages aren’t being triggered at all rather than an issue with messages sending, first step is to confirm the registrant is finalizing the registration (above).

Is there an event I can run a test registration on?


TownCountry

October 16, 2019 at 9:14 am

What steps show completed in ‘Registration Step Progress’?

The step “Finalize Registration” shows “Nie initialisiert” (never initialized).
But we have a lot of registrations with the same status, where the messages were send correctly.

The primary registrant context is not enabled by default so unless you have enabled that context it is expected that it wouldn’t send

We only want to send the “Registration Approved” message to the first registrant. So we changed this.

Is there an event I can run a test registration on?

The site ist password locked. But we can give you access. Do you have a secure way to give you the password?


Tony

  • Support Staff

October 16, 2019 at 12:59 pm

Sure, you can send login details using this form:

https://eventespresso.com/send-login-details/

The support post ‘Messages are not sent reliably’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  Tony 4 weeks, 1 day ago ago

Topic Tags

Notifications

This topic is: not resolved
Do NOT follow this link or you will be banned from the site!
[for="input_96_5_3"]
[for="input_96_5_3"]
[gravityform id=96 title=false description=false]
  • This field is for validation purposes and should be left unchanged.
[i]
[i]
[gravityform id=69 title=false description=false]
  • This field is for validation purposes and should be left unchanged.