Support

Home Forums Multiple Event Registration Add-on MER Not working

MER Not working

Posted: August 9, 2012 at 11:20 am


Candi Stroh

August 9, 2012 at 11:20 am

Newbie here! I have installed MER and not only do i not see any place that its installed other than the plugins tab, but i have no options to include it in any of my events. Please help. I have been at this on my own searching the forums for a solution and have come up empty. Please help!


Josh

  • Support Staff

August 9, 2012 at 11:28 am

Hi Candi,

When you look at the page that lists the events, is there a link to “Add to cart” next to the Registration button?


Candi Stroh

August 9, 2012 at 11:31 am

No here is the page:

http://hbaa.org/wp/event-registration?ee=61

its in draft mode. it shows the additional attendees, but it doesn’t have a place to add to cart so that you can select a different price for the Spouse/Guest.


Josh

  • Support Staff

August 9, 2012 at 11:43 am

Hi Candi,

Here’s a link to a page that lists all the events, and it looks like the Multi Event Registration add-on is working because there are links to add these events to the cart: http://hbaa.org/wp/event-registration

The [ESPRESS0_CART_LINK] shortcode can be added to an event description, and this will display an ‘add to cart link’ on a single event page. See this section of the documentation for tips on how to replace the standard registration form with an add to cart link/button: http://eventespresso.com/wiki/multiple-events-registration-use-add-to-cart-link-instead-of-default-registration-form/


Candi Stroh

August 9, 2012 at 11:51 am

If I replace the standard registration form with a cart link, then how will i get their information that is required to register for an event?
Also, I have two prices one for the member and one for the spouse and I don’t have a place to enter the spouse name and charge for that spouse? How do i set that up?


Josh

  • Support Staff

August 9, 2012 at 12:02 pm

The registration form will appear after the cart selections have been chosen.

To answer your second question, you’ll set “Allow group registrations” to yes and “Additional attendee info” to “Personal info only”.


Candi Stroh

August 9, 2012 at 12:06 pm

Ok i did that, this is what i get now:
http://hbaa.org/wp/event-registration?page_id=1015&regevent_action=load_checkout_page


Josh

  • Support Staff

August 9, 2012 at 12:16 pm

That is a dynamic link that will display information based on the cart selections, so I will not see what you’re seeing.

Can you describe what is not working?


Candi Stroh

August 9, 2012 at 12:22 pm

If you are on this page: http://hbaa.org/wp/event-registration?ee=61
and click “view cart” it takes you to this page:http://hbaa.org/wp/event-registration?regevent_action=show_shopping_cart.
I can select the number of each type of registrant, but no place to enter their name, address, phone number, etc. once a selection has been made, i click on “Finish Registrations” and get this page: http://hbaa.org/wp/event-registration?page_id=1015&regevent_action=load_checkout_page (NOTHING THERE TO CONFIRM). CLick on confirm & get this page: http://hbaa.org/wp/event-registration?page_id=1015&regevent_action=post_multi_attendee (this is only for billing information) STILL NO WHERE TO GET actual registrant and spouse names as well as other important information.


Josh

  • Support Staff

August 9, 2012 at 2:09 pm

Okay, I think I know what might be causing this. Do you have the Roles and Permissions add-on installed? If so, deactivate it.

Then go back to this event and edit it. Then save. The questions should work after that. If they do not, please send WordPress admin level log in credentials via the contact form on this page: http://eventespresso.com/contact/

Select the “I am sending login info as requested” department form and we can take a look.


Candi Stroh

August 9, 2012 at 2:17 pm

The roles and permissions isn’t installed. I have sent you my admin login as requested.


Josh

  • Support Staff

August 9, 2012 at 2:35 pm

Hi Candy,

I’m looking at the site right now. When Event Espresso is installed, there is an Address group that contains the address questions. Can you tell me if the Address question group was deleted, or was it re-named?

Here is more information on how to set up the questions: http://eventespresso.com/wiki/registration-forms/


Candi Stroh

August 9, 2012 at 3:03 pm

Yes I did, i renamed it to Address 1 because it wasn’t showing up on a form at one point and i forgot to change it back. But that can’t be only thing holding it up.


Josh

  • Support Staff

August 9, 2012 at 3:06 pm

I can’t find an address question group at all. Here is what I’m seeing:enter image description here

I’m wondering if this group was deleted at one point. It might cause issues with the question groups since this was a system group.


Candi Stroh

August 10, 2012 at 10:25 am

ok so I will uninstall and reinstall from download and see if that fixes the issue. Will keep you posted.


Josh

  • Support Staff

August 10, 2012 at 11:56 am

Okay, let me know when you are finished, I have more ideas that more help. You can PM me from the account page and I’ll get a notification.


Candi Stroh

August 10, 2012 at 12:31 pm

Well i uninstalled and it didn’t work, i think i have to delete stuff out of my database, because everything was the same when I reinstalled from a fresh download??!?!?!?


Candi Stroh

August 10, 2012 at 12:34 pm

What database files should I be deleting anyway? anything that is wp_events?


Josh

  • Support Staff

August 10, 2012 at 12:40 pm

That’s correct, if you delete the tables that have wp_events, that will clear out all the events, questions, and event data.

enter image description here


Candi Stroh

August 10, 2012 at 1:48 pm

Ok i have it all up and running again. I have created a couple of events, categories, question groups (no renaming). You can view the DRAFT of the event here:
http://hbaa.org/wp/event-registration?ee=5
What am I doing wrong?


Josh

  • Support Staff

August 10, 2012 at 3:36 pm

It looks like it’s working now. If you notice here: http://hbaa.org/wp/event-registration/ the events have a link so they to be added to the cart, and the registration form displays on the screen after confirming the cart selections.

The exception is the draft event. Draft events cannot be added to the cart (this is by design). If you set that event to public, it should display an add to cart link in the event list.


Candi Stroh

August 14, 2012 at 9:11 am

Ok now that we have that working, why will the form not automatically add price when the additional attendee is clicked? I need the spouse/guest registration fee to be added when someone clicks on the additional attendee link, not as a dropdown selection at the top because my people are not going to know to select an additional person link at the bottom.


Candi Stroh

August 14, 2012 at 9:34 am

This page doesn’t allow for an additional Attendee name i.e. the Spouse/Guest to be entered, therefore how am i to know who they are?
http://hbaa.org/wp/event-registration?page_id=1015&regevent_action=post_multi_attendee


Josh

  • Support Staff

August 14, 2012 at 4:44 pm

The page you linked to above is the page that handles the payment info ie. billing info. This will not include fields for any additional attendees. The page before it will though. When I test the annual convention event and select one of each ticket type, there are fields for both attendees:
enter image description here


Candi Stroh

August 15, 2012 at 9:10 am

I think that i have this working now. I do have some other issues with the calendar widget in my footer not posting to pages, but only to posts/pages. I will submit another ticket for that. Also how do i align the fields on the billing/payment page? which file is that?


Chris Reynolds

  • Support Staff

August 15, 2012 at 12:36 pm

Also how do i align the fields on the billing/payment page? which file is that?

Alignment can be done with CSS which can be added either to your theme’s style.css or to the event_espresso_style.css in /wp-content/uploads/espresso/templates


Josh

  • Support Staff

August 15, 2012 at 1:01 pm

It is best to create new topics for additional questions. Form field alignment can be accomplished by enabling the themeroller option in Event Espresso>Template Settings.

Beyond that, you’d probably need to hack the theme’s stylesheet to align the form fields.

The support post ‘MER Not working’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Status: closed

Updated by  Josh 8 years, 1 month ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!