Home Forums Event Espresso Premium Maximum Number Error

Maximum Number Error

Posted: March 20, 2017 at 8:04 pm


March 20, 2017 at 8:04 pm

Hi- My EE events page is giving an error that says: There are 1042 inputs and the maximum amount currently allowed by your server is 1000.
I contacted my hosting company and this is the response their Level 2 Support gave me:

“[Daniel from Support:] Thank you for holding. I do see that you are on a VPS, so we can technically make this change for you, however I want to let you know this can slow down your site. That is a lot of connections for a plugin to the database.

[My response:]Wow. Ok, maybe I need to check on some things first then. What is the normal amount of connections for a plugin?
[My response:] *Average
[Daniel From Support:] About 20-30 max. 1042 is really a lot. I have honestly never heard of a plugin making that many connections.”

Can you please help me fix this? What is causing all of those connections to be active?


  • Support Staff

March 21, 2017 at 5:00 am

Hi there,

Can you please provide a screenshot of the error you are seeing please?


March 21, 2017 at 9:04 am

Here you go: Can you please let me know ASAP? We have many people trying to register. Thanks so much!


  • Support Staff

March 21, 2017 at 9:33 am

Ok so the message shown is telling you how many inputs there are the page and how many inputs your server allows currently, which actually has nothing to do with database connections at all.

It does mean that the data from the input is likely going to be used somewhere and could end up in the database, but having 1042 inputs does not mean you have 1042 database connections.

Each option you can enter a value into (or we use to hold a value), or change something on the page, or pretty much anything that isn’t just visual is going to be an input. Each time you add more tickets/datetimes to an event you add more inputs to the page which can take you over the limit set on your server.

Themes and plugins also add them to the page for various different options.

PHP allows you to set a limit on the amount of inputs you can use per page and the default is usually 1000 (as it appears to be on your site), this is set as the max_input_vars value and can be adjusted to suit, you can do it through your .htaccess file using something like:

php_value max_input_vars 5000
php_value suhosin.get.max_vars 5000
php_value 5000
php_value suhosin.request.max_vars 5000

Which sets the value to 5000.

Or it can be set within the php.ini files on the server (if you are unsure you host can do it for you)

How many tickets/datetimes do you have within your event currently?

Increasing that value will not slow down your site, it will simply allow more inputs to be used on a page which can mean more processing can be done on a single page but does not mean your opening up more and more database connections.

If you need more tickets within the event I’d recommend increasing the max_input_vars value to around 3000 which will give you plenty of space to work with.

The support post ‘Maximum Number Error’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3 Documentation for Event Espresso 4

Status: closed

Updated by  Tony 3 years, 3 months ago ago

Topic Tags



This topic is: not resolved
Do NOT follow this link or you will be banned from the site!