Support

Home Forums Event Espresso Premium Massive E-Mail Problem!

Massive E-Mail Problem!

Posted: October 11, 2016 at 10:48 pm


ARAGATO

October 11, 2016 at 10:48 pm

Two days ago, we went live. Before that I changed my WP SMTP Settings to another server. The mail test worked/works flawlessly. So I thought, everything is fine. Today I noticed 1600+ mails failed to send!!!
I tried SMTP Mail test again and it still works. I tested message template test sending and it did not work. So I figured it had to do something with the EE settings. I then changed the General Email for EE in General Settings and now it work!!! How can it be, that such an important setting is not mentioned anywhere and escpecially not in the setting itself!!

The best part is, after change the general email in EE, message sending works. However, I cannot resend the 1600+ failed emails. It still gives and error.
http://uploads.aragato-server.net/screenshots/2016101287741d0fa1.png


ARAGATO

October 11, 2016 at 11:00 pm

This is the error message when resending the email.
http://uploads.aragato-server.net/screenshots/20161012457fc61af4.png


Josh

  • Support Staff

October 12, 2016 at 7:23 am

Hi there,

You’ll need to re-generate those messages before attempting to re-send them. The original messages did not have a from field.


ARAGATO

October 12, 2016 at 7:30 am

Hi Josh, re-generator of those messages does not work.
http://uploads.aragato-server.net/screenshots/2016101255899995c4.png


ARAGATO

October 12, 2016 at 7:31 am

And why did the original messages have no from field?


Josh

  • Support Staff

October 12, 2016 at 7:59 am

The error message told you to wait a few minutes because there was already a batch being generating. You may need to clear the messages queue before re-generating those messages.

As to why the original messages had no from field, my guess would be either someone removed the short code in the From field of the message template (those value that the short code uses is autofilled with the WP admin email address when you first install Event Espresso) or someone removed the email address that was set in the Primary contact field email set in Event Espresso > General Settings.


ARAGATO

October 12, 2016 at 9:52 am

The error message told you to wait a few minutes because there was already a batch being generating.
I tried it like a thousand times distributed all over the day. Same error all the time. So waiting a few minutes is not going to help.

You may need to clear the messages queue before re-generating those messages.
Where do I do that?

As to why the original messages had no from field, my guess would be either someone removed the short code in the From field of the message template (those value that the short code uses is autofilled with the WP admin email address when you first install Event Espresso)
No, all message templates are prefilled with [CO_FORMATTED_EMAIL]. They have been working before, and now and they work when I test them. They did not work when I changed my SMTP Settings without updating Event Espresso Primary Contact field to match that same address. In the message activity you can see they have a from field.
http://uploads.aragato-server.net/screenshots/20161012af26b647c7.png

someone removed the email address that was set in the Primary contact field email set in Event Espresso > General Settings.
Nobody removed anything. The primary contact field email has been set from the date I first installed EE.


Josh

  • Support Staff

October 12, 2016 at 10:22 am

In that case, your SMTP server might not be able to use the Formatted version of that short code. Instead, you can use [CO_EMAIL].

Or, since you mentioned this:

The best part is, after change the general email in EE, message sending works.

Then maybe the email address you had in there before didn’t work with the SMTP server.

You may need to clear the messages queue before re-generating those messages.
Where do I do that?

In the messages activity list table.


ARAGATO

October 12, 2016 at 10:27 am

In that case, your SMTP server might not be able to use the Formatted version of that short code. Instead, you can use [CO_EMAIL].
Or, since you mentioned this:
The best part is, after change the general email in EE, message sending works.
Then maybe the email address you had in there before didn’t work with the SMTP server.

Then why would it be working now. Besides, the “send test template” function works, too.

The message queue is empty. Nothing to clear there.
http://uploads.aragato-server.net/screenshots/20161012dac514c8f9.png


Josh

  • Support Staff

October 12, 2016 at 11:19 am

Because you changed the email address. You said that after you changed the email address it started working.


ARAGATO

October 12, 2016 at 11:45 pm

Whatever the issue was, it works now.

However, I still need to resend all those failed messages.
Re-generation does not work. Re-sending neither.
Where lies the problem?


ARAGATO

October 13, 2016 at 2:58 am

I just update the 1600+ broken messages manually in the database by changing the ‘wrong’ MSG_from email adress field to the now correct one. Re-generating through the backend admin interface still did not work. Thus, I updated all entries’ STS_ID to ‘MID’ so they were back in the sending queue.
It finally sent the emails. 50 every 5 minutes (cron job interval).

Resolved.

The support post ‘Massive E-Mail Problem!’ is closed to new replies.

Have a question about this support post? Create a new support post in our support forums and include a link to this existing support post so we can help you.

Support forum for Event Espresso 3 and Event Espresso 4.
Documentation for EE3 and EE4
Documentation for Event Espresso 3

Documentation for Event Espresso 4

Status: closed

Updated by  ARAGATO 3 years ago ago

Topic Tags

Notifications

This topic is: resolved
Do NOT follow this link or you will be banned from the site!